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1Introduction

Thank You for purchasing CLARiSOFT.

CLARiSOFT is Videojet Technology’s message design software. It is used to 
create the image to be sent to Videojet’s industrial product coding and marking 
devices for printing. It can either be used in isolation or as part of a coder and 
message network coordinated by CLARiNET. Together, CLARiSOFT and 
CLARiNET make up the core of Videojet’s CLARiSUITE Code Assurance 
Solution.

CLARiSUITE
CLARiSUITE offers powerful, expandable and flexible code assurance solutions 
ranging from simple date codes to serialised shipping container codes. It is a fully 
integrated code assurance solution linking on-product coding to a centralized 
message database.

About the User Manual
This user Manual is a comprehensive guide for the regular users of CLARiSOFT. 
It describes all functions and features of the software as used in isolation or as part 
of a coder and message network coordinated by CLARiNET.

The manual can be used both as a reference guide for the functions found on the 
main screen and dialog boxes of the software as well as a step by step instruction 
manual describing how to create and download messages to coders.

Note: The CLARiTY Coder User Interface examples included in this document are 
not the same for all Coders. The version used for the examples included may be 
different in appearance and operation. In addition, not all functions are available 
in all coders. Please consult the coder manual for details.
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Related Publications
A detailed on-line help is available with CLARiSOFT. Refer to the online help for 
further details on the topics covered in this user manual.

The user manual supplied with CLARiNET contains all required information to 
build a coder network and manage message transfer and synchronisation across 
coders in the network.

Terms and Abbreviations

Term Description

Image, Image File An Image is a collection of Fields that describes how information is to be 
printed on a coder. CLARiSOFT saves Images in a generic file format with 
the CIFF extension.
It is these Image files that are selected by CLARiNET when selecting the 
Next Job for a given coder or group of coders.

Field A distinct item on an Image is called a Field. Fields have their own 
individual properties. Each Field can be positioned relative to other fields 
on the Image.
Each field is of a specific type, e.g. Text Fields, Date Fields etc. and these 
types define the base functionality of the field. The properties of the field 
depend upon its type. A list of fields and their uses are listed later in this 
document.

Field Properties The information, specific to a particular field that sets the exact behaviour 
of that field.
The field properties depend upon the field type. Some field properties are 
shared between differing field types. For example, all field types share 
General Properties and all text-based fields share Font Properties.

Calculated Date Package coding applications frequently use sell-by and use-by dates that 
are calculated by adding a number of days to the current date. 
CLARiSOFT’s Calculated Dates Field provide this feature.

Coder This is the generic term CLARiSOFT uses to refer to any industrial in-line, 
in-plant package coding or labelling machine. Typical types of coder 
encountered in the packaging environment are:

• Continuous Inkjet Printers (CIJ)
• Large Character Inkjet Printers (LCM)
• Thermal Transfer Overprinters (TTO)
• Print and Apply labelling machines
• Laser marking devices
• Thermal Ink Jet (TIJ)

CIFF Videojet’s Coder Independent File Format. This file format is used to store 
Image files.

Table 1-1: CLARiSOFT Terms and Abbreviations
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2Installing and Licensing 
CLARiSOFT

This chapter explains how to install and license your copy of CLARiSOFT. 
CLARiSOFT must be licensed to operate correctly – if unlicensed, it runs in 
demonstration mode whereby image files cannot be saved and will be printed with 
a watermark stating ‘Demonstration Mode’. Random characters are also replaced 
in text fields.

Applications Installed During Installation Process
The CLARiSOFT installation process installs three key applications: 
CLARiSOFT, CLARiSOFT Print Manager and CLARiSOFT Database Manager. 
These applications are described in detail throughout this document and in 
summary below.

CLARiSOFT
CLARiSOFT is the application used to create the image files printed by coders.

CLARiSOFT Print Manager
CLARiSOFT standard functionality allows image files to be downloaded to a 
coder across a network. However, it is not always desirable to allow all users to 
have access to CLARiSOFT simply to print an image; this increases the chance of 
accidental changes to the image structure. With this in mind, Videojet have 
developed CLARiSOFT Print Manager – a standalone application that enables an 
operator to select an existing image file and download it to a coder without the 
ability to change the message structure or content.
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CLARiSOFT Database Manager
CLARiSOFT is supplied with a database to store dynamic data that can be used in 
image files when printing; it can be more efficient and safer to add or change data 
in this database rather than change the contents of image files using CLARiSOFT. 
Data is dynamically inserted into image files from the database when an image 
file is downloaded to a coder. CLARiSOFT Database Manager is a tool to create 
and administer the CLARiSOFT database. CLARiSOFT Database Manager is not 
used when an ODBC data source is in use (see Chapter 7, “CLARiSOFT 
Database”).

Installing CLARiSOFT
Before commencing the installation, ensure that you have sufficient security 
access rights to install the software on the required PC.

Note: CLARiSOFT installs and runs on a Windows operating system only.

CLARiSOFT and CLARiNET should always be upgraded together, i.e. the 
version number of both programs should always be the same. Prior to installing 
CLARiSOFT, ensure that the hardware licence key (‘dongle’) is removed from the 
PC.

Preparing for installation
It is necessary to first uninstall any previous installation of CLARiSOFT from the 
PC. If no previous installation of CLARiSOFT exists, then skip to the section 
“Commencing Installation” on page 2-4.

License File Backup
It is advisable to back up the CLARiSOFT license file prior to removing the 
software. This ensures that, in the event of any mistakes or errors, your license file 
can be restored to avoid re-licensing the new installation.

The license file can be found in a sub-folder of the CLARiSOFT program location 
which is user definable during installation. The default location differs depending 
on installation within a 32bit or 64bit Windows environment.

• 32bit Operating Systems – C:\Program Files\CLARICOM

• 64bit Operating Systems – C:\Program Files (x86)\CLARICOM

Once this installation folder has been located, navigate to the sub folder \data and 
make a copy of the file ‘CLARiSOFT License.xml’ to an alternative location. If 
this file is accidently deleted during installation (see “Removing the existing 
installation” on page 2-3) the new license file, post installation, can be overwritten 
with the backup to restore existing license information.
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Removing the existing installation

Note: Before beginning the uninstall process, make sure that all hardware keys 
(Dongles) are removed from the PC.

1 Open Control Panel. Navigate to the list of installed programs and locate 
CLARiSOFT. Click on the entry to select it and click on the option uninstall. 
After a few moments the following dialog box appears.

2 Click Yes and the following dialog box appears asking if the licensing 
information of the currently installed version is to be deleted. Typically, when 
upgrading, the license file should not be deleted, so click No. Clicking Yes 
will require the software to be re-licensed if the license file is not backed up 
(see “License File Backup” on page 2-2).

Figure 2-1: InstallShield Wizard

Figure 2-2: Confirmation Window
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The uninstall process runs and removes CLARiSOFT from the PC. Once 
completed, the following screen is displayed.

Click Finish to close this window and complete the CLARiSOFT uninstall 
process. It is recommended that the PC is rebooted after uninstalling previous 
versions.

Commencing Installation
1 CLARiSOFT is installed by running a software application entitled 

‘CSxxxxSPy.exe’ where ‘xxxx’ refers to the major version of CLARiSOFT 
being installed and ‘y’ the Service Pack (SP) release. Locate this file 
(typically shipped by Videojet on a USB memory stick). Right click on it and 
select Run as Administrator to begin the setup process.

Figure 2-3: Finish Uninstall
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2 The User Account Control window opens.

3 Click Yes. Following screen is displayed.

4 Click Next to continue setup and be presented with the following screen.

If the default CLARiSOFT installation location is to be changed, click on 
Browse… and select the desired folder. Click Next > to continue. It is 
recommended that the default installation locations are used. Always install 
on the local hard disk (C:), not a network location or secondary hard disk.

Figure 2-4: Commence Install

Figure 2-5: Choose Destination Location
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5 On the following screen, enter the CLARiSOFT installation key that is 
supplied with the installation media.

If this is a new installation, or a reinstallation and the license file was not 
retained, the fields will be blank and the key must be entered. If this is a 
reinstallation and the license file was retained then the fields will contain the 
previous installation key. Click Next >.

The License Agreement window appears (Figure 2-7).

6 Review the license agreement and either click I accept the terms of the 
license agreement followed by Next > to continue with the installation or 
click Cancel to abort the installation.

Figure 2-6: Enter License Key

Figure 2-7: Accept License Agreement
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7 Once Next > is clicked, CLARiSOFT is installed on the PC. After 
installation, the following screen appears informing of success and allowing 
the ability to view the readme file and / or launch CLARiSOFT once Finish is 
clicked.

Click Finish to complete the CLARiSOFT setup.

Post Installation Actions
Under Windows 7 and Windows Server, it is recommended that CLARiSOFT is 
explicitly set to run under the user account ‘administrator’ to ensure all functions 
within the application run correctly regardless of the user access rights.

Note: These steps are not required for Windows XP.

Figure 2-8: Finish Installation
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Right click on the CLARiSOFT entry within the start menu. From the pop-up 
menu that is displayed, click on Properties. The CLARiSOFT Properties dialog 
box appears (Figure 2-9).

Click on the Compatibility tab and then select the check box Run this program as 
an administrator.

Figure 2-9: CLARiSOFT Properties

Figure 2-10: Compatibility
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Click OK to save the changes and close the dialog box.

Repeat these steps for CLARiSOFT Database Manager and CLARiSOFT Print 
manager that are both installed at the same time as CLARiSOFT.

Licensing CLARiSOFT
CLARiSOFT requires a license to be able to function fully.

Activation via Hardware License Key (Dongle)
CLARiSOFT is delivered with a USB-based dongle license key. The dongle must 
be connected to a computer running CLARiSOFT to stop CLARiSOFT running in 
demonstration mode.

Follow the procedure below to activate CLARiSUITE using a hardware key.

1 Open CLARiSOFT (navigate to Start > Programs > CLARiCOM > 
CLARiSOFT).

2 CLARiSOFT displays the message Unactivated or Demonstration Mode at 
the top left hand corner on the title bar.

3 Insert the USB Hardware key (Dongle) into an unused USB port of the 
computer. The system will install drivers automatically. Once the installation 
is complete, the message Unactivated or Demonstration Mode disappears. 
The software is now ready to use.

Note: If the message does not disappear, restart the CLARiSOFT application.

Note: It is recommended that the CLARiSUITE license files are saved to an 
alternative location. This will safeguard against losing the file in case of a PC 
failure, PC reimage or accidental deletion during an upgrade. See the section 
“License File Backup” on page 2-2 for instructions on how to perform this. 
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3User Interface Elements

CLARiSOFT Main Screen

Figure 3-1: CLARiSOFT Main Screen
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Toolbars
CLARiSOFT contains three toolbars enabling quick access to the most useful 
functions required during message design.

Toolbars can be individually displayed or hidden through the View menu.

CLARiSOFT Toolbar
The CLARiSOFT Toolbar contains key functions for user access, file 
management and for editing and positioning of objects on the image design area.

Symbol Description

User level (User Login): If login security is enabled this function 
enables the user to create / manage user security levels and 
permissions (if user has sufficient authorisation).

New Image File (ciff): Create a new image file.

Open Image File (ciff): Open an existing image file.

Save Image File (ciff): Save current image file.

Print Preview: Allows the user to preview the image before
printing / downloading.

Sub Image Preview: If using sub-images, this option allows the user 
to preview and compare up to four sub-images.

Print: Allows the user to print the image files to coder, windows 
printer or a file.

Download: Allows the user to download the image files to coder, 
windows printer or a file.

Delete: Remove the selected item(s) from the image design area.

Table 3-1: CLARiSOFT Toolbar
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Cut: Remove the selected item(s) from the image design area and 
place them onto the clipboard.

Copy: Copy the selected item(s) on the image design area and 
place them onto the clipboard.

Paste: Paste the contents of the clipboard onto the image design 
area (where applicable).

Undo: Undo the last action.

Repeat: Repeat the last action.

Horizontal Center: Horizontal Center alignment of the selected 
fields.

Vertical Center: Vertical Center alignment of the selected fields.

Left Align: Left Edge alignment of the selected fields.

Right Align: Right Edge alignment of the selected fields.

Top Align: Top Edge alignment of the selected fields.

Bottom Align: Bottom Edge alignment of the selected fields.

Horizontal Spacing: Allows to set the Horizontal Spacing between 
the selected fields.

Symbol Description

Table 3-1: CLARiSOFT Toolbar (Continued)
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Vertical Spacing: Allows to set the Vertical Spacing between the 
selected fields.

Bring to Front: Bring the selected field to the Front.

Send to Back: Send the selected field to the Back.

Rotate Left: Rotate the selected field to the left.

Rotate Right: Rotate the selected field to the right.

Select Language: Displays a list of supported languages allowing 
the user to switch the CLARiSOFT application to another language.

About: Displays the version of the software in use.

Help Contents: Displays the contents page of the CLARiSOFT 
on-line help system.

Symbol Description

Table 3-1: CLARiSOFT Toolbar (Continued)
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Format Viewer Toolbar
The format viewer toolbar allows the user to change the image design area zoom 
level, the currently selected target coder and change the target coder.

Element Description

Zoom Controls Enables the user to progressively zoom in to, or out of, the image 
design area using the two magnifying glass symbols or zoom to a 
specific percentage by selecting an option from the drop down list.

Target Coder Description of target coder for which this image is being created.

Selected Template Depending on the target coder, CLARiSOFT needs to know certain 
format / template information. For example, the number of drops high 
a CIJ printed message will be or with a TIJ, how many heads will be 
used. These selections define how CLARiSOFT formats the image 
design area. The selected format / template is displayed in this field.

Select Coder Clicking on this button enables the user to change the target coder. 
CLARiSOFT will retain the objects on the image design area (where 
applicable – depending on coder) and move them to fit if the image 
size is changed.

Table 3-2: Format Viewer Toolbar

Zoom Controls Target Coder Selected Format/Template Select Coder

Figure 3-2: Format Viewer Toolbar
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Database Viewer Toolbar
It is possible to link fields in an image file to external data (see Chapter 7, 
“CLARiSOFT Database” for more information). When this option is being used, 
the ‘Database Viewer’ toolbar enables data from the database to be viewed in the 
associated, linked field in the image design area.

CLARiSOFT Toolbox
The Toolbox contains all field types that can be placed on the image design area. 
These fields are then either printed by the coder or, marked as non-printable and 
used as bases / reference data for other fields. Click on the required field type to 
select it and then click in the required location on the image design area to place 
the field.

Element Description

Job Selector Clicking on the direction indicators enables the user to scroll 
backwards and forwards through the matching jobs (those that use 
the image being edited in CLARiSOFT) in the external database.
Clicking on the button situated between the direction indicators will 
drop down a list of all matching Unique Job Codes from the external 
database; clicking on one of the presented job codes will select that 
job.
The unique job code of the selected job is displayed on the job 
selection button.

Record Number Displayed in the format XX / YY. This read only field indicates that 
record number XX of YY matching records is selected.

Table 3-3: Database Viewer Toolbar

Job Selector Record Number

Figure 3-3: Database Viewer Toolbar
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Field Types

Icon Description

Text fields allow fixed text information such as ‘Lot Number’ or user 
entered information to be included in your printed image.

Time fields insert the current time onto the printed image. The real-time 
capabilities of the selected coder are used to do this.

Inserts the current date onto the printed image. As well as using a coder’s 
real-time ability to print dates it is also possible to derive dates in multiple 
formats in the image and download as text.

A counter field instructs the selected coder to manage and print 
incremental numeric and alphanumeric data.

A price field is similar to a text field with the addition of specific formatting 
for currency data printing.

Displays a list of barcodes commonly printed on secondary packaging (e.g. 
EAN128). Data in the field is converted to the required barcode by the 
selected coder.

Displays a list of barcodes commonly printed on primary products (e.g. 
EAN13). Data in the field is converted to the required barcode by the 
selected coder.

CLARiSOFT enables picture / logo / graphic files to be embedded into an 
image. A wide range of formats are available (.jpg, .bmp, .png, etc.) 
Support for this object type is dependent on the model of coder.

Drawing fields allow lines, boxes and ellipses to be drawn on the image. 
Note that not all coders support drawing graphics.

Text Block fields allow you to define an area of the image where text can 
appear. If the text is too long to fit on a single line it will automatically wrap 
onto the next line. If the text is too large to fit in the text block area, the font 
will automatically be reduced until it fits. This feature is only supported on 
certain models of coder.

Table 3-4: Field Types
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Menu Bar
CLARiSOFT core functionality can be accessed through the CLARiSOFT menus 
and Sub-menus. The table below supplies a high level overview of the functions; 
later sections in the manual will describe the functionality in greater detail.

Menu Sub Menu Key Functions

File New Create a new image file.

Open... Open an existing image file.

Save Save current image file.

Save As… Save current image file under a new name.

User Level… If login security is enabled this function enables the 
user to create / manage user security levels and 
permissions (if user has sufficient authorisation).

Date Calculations… Opens the Date Calculation Manager to enable the 
creation and maintenance of calculated dates, date 
concessions, date rounding and calendar rules.

Data Sources… Enables the user to create and maintain ODBC 
data sources. Used when inserting dynamic data 
from external databases into the message.

Select Coder… Select this option to change the target coder. 
CLARiSOFT will retain the objects on the image 
design area (where applicable – depending on 
coder) and move / resize them to fit if the image 
size is changed.

Properties… This option displays a dialog box containing the 
image file properties (dimensions of image, 
orientation, number of sub-images, etc.). Other 
information is displayed depending on the target 
coder.
The user is able to set coder specific parameter 
values that are downloaded to the coder at the 
same time as the image file. The parameters 
available depend on the target coder but instruct 
the coder to perform specific functions such as 
invert print, reverse print, set character gap inverse 
or set the start of day.
Depending on the target coder, this dialog box can 
also present tools to create and manage sub-
images and print-head assignment. (Used in 
multiple printhead and master/slave applications).

Print Preview… Allows the user to preview the image before 
printing / downloading.

Table 3-5: CLARiSOFT Menu
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File 
(Continued)

Sub Image Preview If using sub-images, this option allows the user to 
preview and compare up to four sub-images.

Print The Print and Job Download dialog boxes perform 
the same task in current versions of CLARiSUITE. 
The two options remain for backward compatibility 
purposes only. Throughout this manual, when 
referring to “Printing”, either of these options are 
interchangeable.

Job Download

Recent files Displays the 6 most recently opened image files. 
Selecting one of the entries will open the image file 
for editing.

Exit Close current image file (if applicable) and quit 
CLARiSOFT.

Edit Undo Undo the last action.

Redo Repeat the last action.

Cut Remove the selected item(s) from the image 
design area and place them onto the clipboard.

Copy Copy the selected item(s) on the image design 
area and place them onto the clipboard.

Paste Paste the contents of the clipboard onto the image 
design area (where applicable).

Delete Remove the selected item(s) from the image 
design area.

View Toolbar Display or hide the main CLARiSOFT Toolbar.

Status Bar View or hide the Status Bar.

Format Viewer View or hide the Format Viewer.

Database Viewer View or hide the Database Viewer.

Zoom In Zoom in one step on the image design area.

Zoom Out Zoom out one step on the image design area.

Menu Sub Menu Key Functions

Table 3-5: CLARiSOFT Menu
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Tools Alignment Displays a sub-menu with options for aligning and 
spacing / distributing selected items on the image 
design area.

Rotation Displays a sub-menu with options for rotating 
selected items on the image design area.

Field Order Allows control over the field order for printers 
where the order of sending data is essential.

Select Language Displays a list of supported languages allowing the 
user to switch the CLARiSOFT application to 
another language. Changes the application 
dialogue boxes, menus, etc. – not the content of 
the image design area.

Options… Displays a dialog box allowing user to configure 
primary application settings such as editing 
preferences, working directory, enabling login 
control, SSCC setup, printer connectivity, database 
configuration and print mode (batch or sequence 
mode). These functions are described in detail 
throughout this manual.

Start of Day By default, dates are incremented at midnight. This 
option enables the date changeover to be set to 
any other time.

Help Contents Displays the contents page of the CLARiSOFT 
on-line help system.

Activate… Leads the operator through the process of 
activating the software if using software, rather 
than hardware (dongle), licensing. Software 
licensing is available only in certain instances – 
contact your local Videojet representative for more 
information.

About CLARiSOFT… Displays the version of the software in use.

Menu Sub Menu Key Functions

Table 3-5: CLARiSOFT Menu
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Status Bar
The status bar displays the following information:

• Status messages

• x and y position of the cursor for accurate positioning

• Selected unit of measure

• User ID currently logged in (if user login functionality enabled)

• Sub-image number (if one is in use)

Figure 3-4: Status Bar
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4Basic Image Creation

This chapter introduces the basic elements of image design via the creation of 
three basic images:

1 Use by date printed by a Continuous Ink Jet device to explore text and date 
fields.

2 Secondary packaging image printed by a Large Character printer on a carton 
which introduces Logos, Barcodes and Drawing Objects.

3 Enhancing example two above to automatically increment the box number as 
each is printed. This example describes how to use counter fields, non-printed 
items and merge fields.

It is recommended to work through these examples in sequence to build a sound 
understanding of core CLARiSOFT functionality. For instructions on how to print 
image files see Chapter 5, “Printing in CLARiSOFT”. All sample image and 
graphic files used in these examples are shipped with the electronic version of this 
manual in the ‘Sample CIFFs’ folder.

Basic Image Containing Use-By Date
This image contains static text and a date field displaying a use-by date. The 
operator is prompted to enter the use-by date when the job is selected. Date 
functions is covered in more detail in Chapter 6, “Date Calculations”.
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Define Target Coder
1 Click File > New to create a new image. The following screen is displayed. 

Select a target coder and image / size options.

2 For this example, print using a Videojet 1620 WSI Continuous Ink Jet. Click 
Videojet > WSI > WSI 1620 in the list below Select the Coder you wish to 
design for.

3 From the Select Format drop down list, select 12-High. This tells 
CLARiSOFT that the image to be printed as 12 dots / drops high and it sets 
the Image Design Area to the corresponding height.

4 Leave the value in field Enter Image Width(mm) at 100.00. The Enter Image 
Height(mm) field is disabled, when printing via a CIJ, the Select Format 
option defines the height of the print area.The screen is displayed as follows.

Figure 4-1: Select Coder

Figure 4-2: Select Format
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5 Click OK to close the dialog box and start editing the image. CLARiSOFT 
sets the image design area to match the dimension set on the previous screen.

Create a Static Text Field
6 Click the Text tool in the toolbox. CLARiSOFT automatically places a text 

box on the image design area and displays the Text Properties dialog box:

Figure 4-3: CLARiSOFT Main Screen

Figure 4-4: Text Properties
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7 Enter into the Default Text field the text Use By: . Ensure there is a space at 
the end of the text. Click Apply. The dialog box appears as follows:

Figure 4-5: Text Properties -Text
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8 In this step, increase the size of the font to match the height of the Image 
Design Area (as defined in Step 3 above). Click on the Font tab and change 
the font size to 12 High International by selecting this option from the drop 
down list below the text ‘Font Name’. Click Apply.

Figure 4-6: Text Properties - Font
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9 Click on the General tab to give this field a unique, meaningful name. Whilst 
CLARiSOFT assigns each field in an image a unique name it is good practice 
to assign meaningful ‘friendly’ names. In the Field Name box enter 
‘txtUseBy’. Click Apply.

Figure 4-7: Text Properties - General
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10 Click OK to close the dialog box. The image design area should look like the 
following image.

Create a User Entered Date Field
11 Click on the Date tool in the CLARiSOFT Toolbox. A date field is placed on 

the image design area (next to the static text entered previously) and the Date 
Properties dialog box appears.

Figure 4-8: Image Design Area

Figure 4-9: Date Properties
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12 For this job, we want the operator to enter the ‘Use-By date’ whenever the 
job is printed. To do this, select the option User Entered Date from the drop 
down list located below ‘Date Type’.

13 Within the Date Properties dialog box, set the Font size to be 12 High 
International on the Font tab and give the field a friendly Field Name of 
‘dtUseByDate’ on the General tab.

14 Click OK to save the properties and close the dialog box. The previously 
added date field is set to display the current date and CLARiSOFT should 
look as follows:

Figure 4-10: Image Design Area
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Saving the Image File to Disk
15 CLARiSOFT saves image files to the user-definable default working 

directory. Click Tools > Options... to display the CLARiSOFT Options dialog 
box and then click on the General tab. The following screen is displayed 
where it is possible to select a new working directory by clicking on the 
Browse button: 

16 Click OK to save changes and close the CLARiSOFT Options dialog box.

17 Click File > Save As... to display the standard Windows save dialog box. 
Select the required storage location (if different from the working location 
defined above), enter a file name (for this example set the file name to be 
BasicUseByDate) and click Save. CLARiSOFT appends the extension ‘.ciff’ 
to image files.

Figure 4-11: Save Image
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Basic Image for Secondary Packaging
This example describes the steps required to build a typical carton / secondary 
packaging image and introduces new tools / fields: Logos, Barcodes and 
Drawings. It also introduce the object alignment and spacing tools.

An example of the completed image: 

Define Target Coder
1 Start a new image in CLARiSOFT (File > New) and in the target coder 

selection screen select Videojet > CLARiTY > Videojet 2360. The Videojet 
2360 is a Large Character Marking (LCM) coder ideally suited for printing 
directly onto shipping cartons.

2 Set the image width to 260mm and leave the height at 70.52mm (the 
maximum print height for the Videojet 2360 print head).

3 The Videojet 2360 does not have any print templates / settings that are 
affected by the Format drop down list so this can be left at ‘Default’.

4 Click OK.

Insert a Logo
5 Click on the Logo tool in the Toolbox and then click in the image design area 

at the location to place the object. For this example click approximately at 
coordinates 5, 5 (millimetres across and down from the top left corner of the 
image design area – the status bar indicates the current x & y position). A 
sample logo is placed at the selected location and the Logo Properties dialog 
box appears.

Figure 4-12: Secondary packaging Image
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6 Click the Browse button and locate the file ‘CLARiSUITE Logo.jpg’ (note 
that the ‘File Type’ will need to be changed to ‘jpg’ in the File Open dialog 
box). Select the file and click Open to return to the Logo Properties dialog 
box. 

Figure 4-13: Logo Properties
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7 If required, explicitly set the size of the logo on this tab and give the field a 
‘friendly name’ on the General tab. Click OK to close the dialog box and 
insert the selected graphic into the image. 

Note: CLARiSOFT work only with monochrome logos and automatically 
convert colour sources files if required.

Figure 4-14: Logo on the main screen
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8 The logo is too big to entirely fit in the image design area. If CLARiSOFT 
cannot print an object correctly, it changes its colour from black to red. This 
occurs if the object is partially (or fully) off the image design area or if the 
object overlaps with another object or the target coder cannot support 
overlapped fields. Resize the logo by dragging the bottom right corner 
(indicated with a small, blue square) diagonally up to the left. Reduce the size 
so that the bottom of the logo is approximately 5mm above the bottom of the 
image design area as seen in the following screenshot:

Figure 4-15: Logo Resized
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Insert a Drawing
9 In the finished image, there is a rectangular box around its perimeter; this is 

added using the Drawing tool. Click on the Drawing tool in the Toolbox and 
clicking on the location of the top, left hand corner of the rectangle. The 
Drawing Properties dialog box appears.

10 As the default drawing shape (‘Primitive Type’) is the required Outline Box, 
click on OK to insert the drawing shape and close the dialog box. 

11 The inserted outline box is not big enough; drag the bottom, right corner of 
the box (as highlighted with a small, blue square) until the box is 
approximately 3mm from all edges of the image design area. Objects can be 
selected by clicking on them.

Figure 4-16: Drawing Properties
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Inserting a Barcode
CLARiSOFT offers a wide range of industry standard primary and secondary 
packaging barcodes which is printed by coders with in-built support for the 
selected barcode. If the coder does not support a specific barcode it is not possible 
to add that barcode to the image.

12 For this example include an ITF barcode; a 14 digit Global Trade Item 
Number (GTIN) commonly used on secondary packaging. Click on 
Secondary Barcode in the Toolbox and then click on the required print 
location in the image design area (for this example approximately 130, 35 
using the coordinates in the status bar). A list of available secondary barcodes 
is present.

13 Click on ITF and then OK to close the barcode selection dialog box and 
display the ITF Properties dialog box. This dialog contains the required 
parameters to correctly design and populate an ITF.

Figure 4-17: Select Barcode

Figure 4-18: ITF Properties
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14 CLARiSOFT places a default value in the Barcode Data field. Enter a 14 
digit numeric value in this field (CLARiSOFT allow longer or shorter lengths 
but there must always be an even number of digits) and give the field a 
friendly name of ‘bcITF’ on the General tab. Click OK to close the ITF 
Properties dialog box.

Adding Text Fields
15 To complete the design of the image add two text fields above the ITF 

barcode. The upper most text field should have the default text of 
CLARiSOFT Software in Arial 30 point (fonts are changed via the Font tab on 
the field properties dialog box) and the lower text field should state Box 1 of 1 
in Arial 16 point. The image should look something like the following screen 
shot.

Figure 4-19: Image Design Area

Figure 4-20: Final Image
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Aligning and Spacing Objects
16 Click on the text field CLARiSOFT Software to select it and then hold the 

Shift key on the keyboard whilst clicking on the text Box 1 of 10 and the ITF 
Barcode. This selects all three objects.

17 Click on the Horizontal Centre button on the toolbar or Tools > Alignment > 
Horizontal Alignment from the menu. This aligns the centre points of all three 
objects.

18 With the same three objects still selected click on the Vertical Spacing button 
on the toolbar (or Tools > Alignment > Vertical Spacing) from the menu. The 
spacing dialog box appears; enter 5 in the Field Spacing box to ensure a 
unified 5mm gap between each object. The image will now look like:

Save the Image
19 Click File > Save As... and select the required location for storing the file. For 

this example use the file name ‘Secondary with ITF’ and click Save.

Basic Image with Counter Field
This example extends the functionality and flexibility of the image file created in 
the previous example. The field stating Box 1 of 10 is altered so that the box 
number automatically increases by one with each print. 

This is performed by building up a text field variant called a Merge Field that 
consists of three other non-printed fields concatenated together: two text fields 
and the counter field. 

Figure 4-21: Aligned Image
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A reminder of how the final image will look.

Prepare the image file
1 Locate and open the image file created in the previous example (‘Secondary 

with ITF.ciff’).

2 Save the file under a new name (‘Secondary with ITF and Counter.ciff’) 
using the standard File > Save As… functionality.

Create the Supporting Text Fields
3 Click on the Text tool in the toolbox and click on the CLARiSOFT 

background area to place the field. As this text is not printed but used instead 
within another printed field, it is OK, and normal practice, to place this off the 
image design area. The default text should read ‘Box’ (note the trailing 
space). Give this field a friendly name of ‘txtBeginningText’ on the General 
tab and select the Non-printed option on the same tab. Click OK to save the 
properties and note that the field is now be grey in colour to indicate a non-
printed field.

Figure 4-22: Final Image
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Repeat the steps in point three above to create another text field called 
txtEndingText that has the default text of ‘ of 10’ (note the leading space) that 
is also non-printed. The two fields Options dialog boxes should look as 
follows:

Figure 4-23: Text Properties

Non-Printed Fields

Figure 4-24: Image with Non-Printed Fields
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Add a Counter Field
4 A counter field instructs the coder to increment a numeric / alpha / alpha-

numeric field by a certain amount at each print. It is the coder that manages 
the incrementing – the message is not downloaded for each print.

Click on the Counter tool in the toolbox and then place the counter field next 
to the two supporting text fields created in the previous step.

5 Ensure Numeric is selected from the drop down list below Type on the 
Numeric tab of the Counter Properties dialog box. This tells the printer to 
print and increment a numeric field.

6 Set the Number of Digits to 2 (as the largest number that is printed is ‘10’).

7 Select the No Padding option as we do not want the number printed as ‘01’ or 
‘ 1’.

8 Set the Start Value to 1 and End Value to 10 as we do not want to print a 
figure above 10 (the maximum number of boxes). The Step Size should be set 
to ‘1’ to tell the printer to increment the number by one at each print. The 
Numeric tab of the Counter Properties dialog box should now look like:

9 Set the font to 15 point and on the General tab supply a friendly field name of 
‘cntBoxNo’ and specify that this field is Non-printed.

Figure 4-25: Counter Properties
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Create a Merge Field
10 To ensure the label is printed as clearly and professionally as possible with 

correct character spacing, now build a ‘Merge Field’ consisting of the 
beginning text, counter, and ending text concatenated together. Double click 
on the text field Box 1 of 10 to display its properties dialog box. Alternatively, 
right click on it and select Properties… from the pop-up menu that appears.

11 The Type drop down list is currently set to Fixed Text (the default). Change 
this to Merge Field by selecting this option from the list. A new button 
entitled Merge… appears.

12 Click on the Merge… button to display the Field Merger.

Figure 4-26: Merge Field

Figure 4-27: Field Merger
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13 A list of available fields that can be merged appear in the left list box (a good 
example of why friendly field names are so important). Select and add the 
fields that need to be merged so that they appear in the Selected Fields list 
box. The sequence in which they are concatenated can be altered using the 
Move Up and Move Down buttons.

Add the txtBeginningText, cntBoxNo and txtEndingText to the Selected Fields 
list box and sequence them so that the Field Merger looks as follows.

Click OK to close the Field Merger and OK again to close the Text Properties 
dialog box.

14 The image file is now completed. At every print, the merge field displays the 
correct box number based on the Non-Printed counter field.

15 Save the image (File > Save).

Figure 4-28: Order Selected Fields

Figure 4-29: Final Image with Merged Fields
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5Printing in CLARiSOFT

CLARiSOFT offers flexible printing options that fall primarily into offline and 
online modes:

• Offline: The required image files are transferred to the coder via a storage 
device such as a USB stick and stored in the coder’s memory for future use.

• Online: The image file is transferred to a device via TCP/IP or RS232 serial 
cable for printing.

Many printing and image file management features are coder specific. Please 
check the specific features of your coder to understand capabilities.

CLARiSOFT can also print to Windows printers using the standard Microsoft 
Windows printer drivers and print management functions.

Offline Printing
When offline printing, it is necessary to transfer the image file or files to the 
required coder or coders and use the features of the coder to transfer the image file 
to the coder’s memory. Once in memory the image file can be retrieved and 
printed upon demand.

Please consult your coder’s documentation to understand its file management 
capabilities and processes required to transfer the image file from the storage 
device to the coder. 

If CLARiSOFT is used to modify the image file then the image stored in the coder 
will need to be replaced with the new image to pick up the changes. Furthermore, 
the new image will need to be re-selected for printing at the coder interface.

Images should never be transferred from a coder to a memory stick for editing in 
CLARiSOFT - this usually results in an image being rotated by 90 degrees. 
Instead, edit the file originally created by CLARiSOFT.
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Download a Job File using USB Memory Stick
Do the following tasks to download a job file from the PC to the printer using a 
USB memory stick:

1 Insert the USB memory stick into the PC.

2 On the File menu, click Job Download.

3 The Download dialog box appears.

4 Select Real-Time Coder under Printer Type.

Figure 5-1: Job Download

Figure 5-2: Download Dialog Box
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5 Make sure that the correct printer is displayed under Select Output Device.

Note: If the correct output device is not selected, the image will not be correct 
for the printer.

6 Select Print to File under Image Options.

7 Select the USB memory device to use from the drop down list.

Note: The ‘Print What’ option will not be available until a suitable memory 
device is selected.

8 To download only the currently opened job file, select Current Image under 
Print What?.

To download multiple job files that have been saved to the PC, select File and 
navigate to the location in the PC where the files are stored. Highlight the 
jobs to be transferred and click Open.

9 The Job Selection Confirmation dialog box appears.

10 Click OK. CLARiSOFT displays the download progress. Click Close when 
the download is complete.

Figure 5-3: Job Selection Confirmation

Figure 5-4: Download Progress
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Caution

When transferring an image using a USB memory stick, failure to use Print 
to File procedure will result in errors and rotated images.

11 Remove the USB memory stick from the PC.

Online Printing
Online printing offers increased levels of flexibility and functionality by allowing 
an image file to be transferred directly from CLARiSOFT to the coder over TCP/
IP or an RS232 Serial cable. This option requires the coder to be connected either 
to an Ethernet network or directly to the computer running CLARiSOFT.

CLARiSOFT Print Manager, a standalone software application installed at the 
same time as CLARiSOFT, offers online printing functionality of image files 
without the requirement of first opening the files in CLARiSOFT. This reduces 
the risk of undesired or accidental changes to the image file contents whilst open 
in CLARiSOFT.

For more information refer to Chapter 9, “CLARiSOFT Print Manager”.
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Configuring Printer Communications
Connection must be established to the required non-Windows, online printer to 
enable online printing directly from CLARiSOFT.

Within CLARiSOFT click on the Tools menu and then Options… to display the 
CLARiSOFT Options dialog box.

Click on the Printing tab to display and edit the printer configuration options.

Connection via Serial Port
If the required coder is connected via serial port select the option Use Serial Port 
Communications. The serial port configuration options is enabled and the TCP/IP 
options is disabled.

Enter the required serial settings that match those of the printer being printed to. 
Click OK to save the changes and close the dialog box. CLARiSOFT is now ready 
to print to this online printer via serial communications.

Figure 5-5: Communication Setup
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Connection via TCP/IP
If the required coder is connected over a network using TCP/IP select the option 
Use TCP/IP Communications. Serial communication options is disabled and the 
TCP/IP address and port fields is enabled.

Enter the TCP/IP address of the required printer and the communication port to 
communicate through. Click OK to save the changes and close the dialog box. 
CLARiSOFT is now ready to print to this online printer via TCP/IP 
communications.

Print Preview
CLARiSOFT offers a powerful print preview function to enable you to review the 
image before printing.

Click on the File menu and then Print Preview to view the print preview dialog 
box. This can also be achieved by clicking on the print preview button on the 
CLARiSOFT toolbar.

Select Image to Preview
Use this option if working with sub-images to select the sub-image to review.

Figure 5-6: Print Preview
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Select zoom (%)
By default the Best Fit option is selected to display the entire image file in the 
print preview. The zoom level can be adjusted by selecting a pre-defined zoom 
level from the drop down list. Left or right-clicking on the preview is also zoom in 
and out.

Image Attributes
The image size and percentage of image that is printed is displayed below the 
preview. This is useful to allow you to reduce the amount of ink used. The number 
of ‘Pixels’ indicates the amount of ink which is used for printing the current 
message – this is used to calculate the approximate number of prints achievable 
per unit (bottle, cartridge) of ink.

Preview As
This option allows to preview the image as it would appear printing on a different 
coder. CLARiSOFT reformats the design to match the coder’s capabilities. If 
CLARiSOFT perceives that printing errors occurs (fields don’t fit, unsupported 
fonts, etc.) the preview tool displays an error report with a detailed list of reasons. 
The Problem Fields button also displays the error report.
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Coder Format Preview
The different formats / templates supported by the coder can be selected here to 
see the changes to the image that would occur if that format / template were used 
during printing.

The image below shows the preview of the previously created carton image 
(designed for a Videojet 2360 LCM) if it were to be printed on a Videojet 8510 
TIJ. The image is too big for the 8510 even when selecting the 4-head format.

Figure 5-7: Coder Format Preview
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Printing the Image
Select File > Print from the menu (or click on the print button from within the 
CLARiSOFT toolbar) to print an image.

Printer Type
Select the option to print either to a Windows printer or to a real-time coder. This 
tells CLARiSOFT if it should print to a regular desktop printer (such as a Laserjet) 
via the Windows printing sub-system or if it should download to the printer we 
established connection to earlier in this chapter (see “Configuring Printer 
Communications” on page 5-5).

Output Device
If printing to a Windows printer is selected, this list contains the printers 
configured within the Windows operating system in which CLARiSOFT is 
running (the same list of printers that would available to applications such as 
Microsoft Excel or Word).

If the Real-Time Coder option is selected, this option is default to the coder for 
which the message has been designed. It is, however, possible to select another 
coder from within the list. Be aware that selecting another coder may seriously 
impact the format and content of the image file. Ensure you have previewed this 
image design on the required coder (using the print preview functionality) first.

Figure 5-8: Print Image
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Number of Prints
Depending on the coder selected it may be possible to request a specific number 
of prints. This is useful when working with a coder such as a standalone label 
printer and it is necessary to print multiple labels. This field is only enabled if the 
destination coder supports multiple print quantities.

Image Options
Only enabled if printing to a Real-Time Coder

• Download: Download the image to the coder and store in memory but do not 
select the job for printing.

• Download and Select: Download the job to the coders memory and select the 
job for printing.

• Print to file: Downloads the CIFF file to external storage device. Creates a 
folder called Jobs from the root of the storage device and stores the selected 
CIFF file in that folder. Also creates folders called Fonts and Graphics which 
store any non-standard fonts and any graphics used in the image design 
respectively. Simplifies the offline process of transferring the image to the 
required coder. This is the recommended way to transfer jobs to a CLARiTY 
printer. Copying the CLARiSOFT CIFF file directly to a USB stick is not 
recommended.

Note: ‘Download’ is not prompted for any variable information at the PC, 
however all variable information required by the image is prompted AT THE 
CODER.

Note: ‘Download and Select’ prompts for any variable information required 
by the image AT THE PC, and then download it to the coder as fixed text. If 
the image is subsequently selected at the coder, the variable information is 
not prompted.

Print What
• Current Image: Prints the currently opened image in CLARiSOFT.

• File: Allows you to select the CIFF file to print.

• Database record: Selects the CIFF file and external data to be printed from an 
external database. See Chapter 10, “CLARiSOFT Database Manager” for 
more information.
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6Date Calculations

CLARiSOFT offers flexible date management functions that work in combination 
with the coders printing CLARiSOFT messages. These functions work to either 
completely remove the requirement to manually enter dates by automatically 
calculating the correct date or by strictly controlling dates that are manually 
entered by offering date selection rather than keyed data entry.

These functions remove the ability for an operator to manually enter the incorrect 
date.

User Entered Date
If the operator must manually enter a date, then CLARiSOFT can constrain these 
dates to a range of dates that can be selected from, rather than manually keyed in.

The following example shows the procedure to create a date field and calculate a 
range of dates based on it. The operator can chose a date from this calculated 
range, during job selection.

1 Click File > New to create a new image. Select the coder and image / size 
options as shown in Figure 6-1.

Figure 6-1: Select the Coder
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2 Click OK.

3 Click on the Date tool in the toolbox. CLARiSOFT places the current date on 
the image design area and displays the Date Properties dialog box.

4 In General tab of the Date Properties dialog box, give this field a unique 
meaningful name (‘dtUserEnt’ in this example). See Figure 6-2.

Figure 6-2: Date Properties
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5 In the Text tab, select the option User Entered Date from the Date Type drop 
down list (see Figure 6-3). Selecting this option lets CLARiSOFT send the 
required commands to the coder to instruct it to prompt for a date selection 
during job set up.

6 Select Coder Date under Date to Use. By selecting this, the dates that the 
operator can select will be derived from current date in the coder rather than 
the current date in the PC.

7 In this example, we will generate a date using a date offset. A date offset is 
calculated from an offset value, which can be a number of days, months or 
years. We will generate a date, or range of dates using a defined offset period 
from the base date, defined in Step 6 (coder date). 

Select Days from the Minimum Offset Units drop down list.

8 Select the minimum offset as ‘5’ and maximum offset as ‘10’. CLARiSOFT 
calculates the offset dates based on the coder date. The operator will only be 
able to select a date between these calculated offset dates.

In this example, the operator will be able to select a date between 5 days and 
10 days from the current date in the coder during job selection for printing.

9 Enter a prompt message that is to be displayed when the operator selects the 
job (Please Enter the Date in this example).

Figure 6-3: Date Properties-Text tab
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10 Save the image file to the disk. Name the file as ‘User entd date’. Note that 
this will be the name of the job in the printer for selection, once we transfer 
this message to the printer.

11 Make sure that the computer running CLARiSOFT is connected to the coder.

12 Click File > Print. The Print dialog box appears.

13 Select Download under Image Options. 

14 Select Current Image under Print What. 

15 The Job Selection Confirmation dialog box appears. Verify that the preview 
is correct and click OK.

16 The job download starts. CLARiSOFT displays the progress. Click Close 
when the download is complete.

Figure 6-4: Print

Figure 6-5: Download Progress
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17 At the coder’s user interface, touch the Job button. The transferred image 
appears in the job select list. Note that the job name ‘User entd date’ is the 
same as the CIFF file name given in Step 10.

18 Select the job and touch OK.

19 The prompt message created in CLARiSOFT in Step 9 appears (see Figure 6-
7).

20 Touch Edit. 

Figure 6-6: Job Select

Figure 6-7: Prompt Message
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21 The coder calculates a range of dates that can be selected based on the current 
coder date and the offsets that we defined earlier.

22 Select the required date from the available dates by touching the required 
date. The dates between the minimum and maximum offset days are 
displayed in white and are available for selection. All other dates are disabled 
and cannot therefore be incorrectly selected by the operator. The current 
coder date is shown in a red box and the current selection in blue. Touch OK.

23 A tick mark appears showing that this user entered field has been completed. 
The date is changed to the selected date in the preview.

Figure 6-8: Select Date

Figure 6-9: Updated Date
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24 Touch OK. The print preview is displayed.

25 Touch OK to close the preview display. The job with the required date is now 
ready for printing.

Figure 6-10: Job Preview
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Chained Dates
A chained date is one which is calculated based on another existing date. In this 
example, we will create a Sell By date which is a calculated offset date from the 
current date. Then we will calculate the Display Until date which is a chained 
date, based on this sell by date. 

1 Create an image selecting the Coder as Videojet 1650 and Select format as 
12-high. 

2 Create a fixed text field Sell By and name this field as ‘txtSellBy’ in the 
General tab.

3 Create another text field Display Until and name this field as 
‘txtDisplayUntil’ in the General tab.

4 Create a date field to the right of ‘txtSellBy’ and name this field as ‘dtSellBy’ 
in the General tab. Leave all the parameters as default for now.

5 Create a date field to the right of ‘txtDisplayUntil’ and name this field as 
‘dtDisplayUntil’ in the General tab. Leave all other parameters as default for 
now. The image design area should look like Figure 6-11.

We will now change the first date field ‘dtSellBy’ as a calculated offset date 
on the current date.

6 Double click the ‘dtSellBy’ field. In the Date properties dialog box that 
appears, from the Date Type drop down list, select Calculated Date. Click on 
Calc Manager.

7 Click New in the Date Calculation Manager dialog box to generate a new 
date calculation. A date calculation can be used more than once within a 
CIFF file.

Figure 6-11: Date Field Image
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8 In the Date Calculation Properties dialog box, enter the Calculation Name 
‘calcSellByOffset’. Leave the Reference Date as Current Date and select 
Within Image from the Source drop down list to tell CLARiSOFT to calculate 
a new date based on the current date in the existing image.

Note: Make sure that a unique, meaningful name is entered for the date 
calculation.

9 Set the Default Offset as ‘30’ and Units as ‘Days’. The ‘Sell By’ date will be 
calculated by adding 30 days to the current date.

10 Click Apply and then click OK.

11 The calculation name appears in the Date Calculation Manager dialog box. 
Click OK.

Figure 6-12: Date Calculation Properties

Figure 6-13: Date Calculation Manager
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12 A preview of the calculated date appears in the Date Properties dialog Box. 
Click OK.

13 CLARiSOFT displays the calculated ‘Sell By’ date in the Image Design area. 
Note that the Display Until date is still the current date. In the following 
steps, we will calculate this date based on the ‘Sell By Date’.

Figure 6-14: Date Calculation Properties

Figure 6-15: Chained Date based on another date
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14 Double click on the ‘dtDisplayUntil’ field. In the Date Properties dialog box 
that appears, from the Date Type drop down list, select Calculated Date. 
Click on Calc Manager. 

15 Click New in Date Calculation Manager dialog box to generate a new date 
calculation.

16 In the Date Calculation Properties dialog box, enter the Calculation Name 
‘calcDisplayUntil’. From the Reference Date drop down list, select 
‘calcSellByOffset’ to tell CLARiSOFT that the calculation will be based on 
this date.

17 Select Within Image from the Source drop down list.

18 In the Default Offset box, select -2. This means the ‘Display Until’ date will 
be calculated by reducing two days from the ‘Sell By’ Date.

Figure 6-16: Chained Date based on another date
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19 Click OK to exit the dialog box. Click OK to close Date Calculation 
Manager dialog box, which now has two calculation names in it.

20 Click OK to close the Date Properties dialog box.

21 The image will now look like

Note that the Sell by date is 30 days after current date (which is 21/10/2013) 
and the display until date is 2 days before the Sell By date.

Figure 6-17: Date Calculation Manager

Figure 6-18: Final Image
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7CLARiSOFT Database

CLARiSOFT has the ability to link to external data sources to include dynamic 
data in messages at the time the job is downloaded to the printer. By default, 
CLARiSOFT uses its own database called ‘CLARiSOFT Database’ but can also 
be configured to use an external database if so desired.

Overview
Placing data that needs to be printed within a CIFF file can be inconvenient if that 
data changes with each new job / batch (such as prices, serial numbers or lot 
numbers). To open the CIFF file, edit the data and save, is inefficient and also 
introduces risk. Whilst editing the CIFF file it is possible to accidently change 
field placement, data content etc. It may also not be desirable to give operators the 
ability to edit CIFF files.

CLARiSOFT comes with a powerful feature to avoid these issues – the ability to 
link fields within a CIFF file to a job database. With this functionality, the CIFF 
file will contain a mixture of static text that will not change and links to data in the 
database for the dynamic data. The data from the database is merged into the CIFF 
file before download.

A database contains jobs and jobs contain the data that needs to be merged into the 
CIFF file. Each job can use a different CIFF file or a CIFF file can be used by 
multiple jobs – further increasing efficiency. Simply adding a job to the database 
or changing data in a job will result in an updated message being printed with no 
need to edit the CIFF file(s). See Chapter 9, “CLARiSOFT Print Manager” for 
information on CLARiSOFT Print Manager – a tool to print messages without 
having to open the file in CLARiSOFT.

A sample database is supplied with CLARiSOFT that shall be used in the 
following example. See Chapter 10, “CLARiSOFT Database Manager” for more 
information on administrating the CLARiSOFT Database and editing the job data 
contained within it.

The following sections explain how to link a CLARiSOFT CIFF file to data in the 
sample database.
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CLARiSOFT Database Structure
CLARiSOFT is supplied with a sample database, that contains common data 
elements used in the product coding and marking industry (see Figure 7-1). You 
can configure this built-in, default database to suit your needs.

The CLARiSOFT database structure and format is defined below:

• Each row refers to a job. A job must have a unique reference so that 
CLARiSOFT can identify a specific job from amongst all the jobs in the 
database. The job defines the dynamic data to be printed (i.e. price, lot 
number, etc.) as well as meta data that CLARiSOFT uses to manage the job 
such as unique job code, name of message file(s) used with this job and other 
data that is used when integrating this job data with multiple coders in a 
CLARiNET coder and messaging network.

• Each column, which has a unique name, holds a specific item of dynamic 
print data or metadata used within a job. CLARiSOFT requires a certain 
number of columns to exist to be able to function correctly, all other columns 
are user definable to enable a company to store the specific data they need for 
their jobs. 

From Figure 7-1, it can be seen that each row refers to the print jobs for a 
company manufacturing food products and columns hold such information as 
the source data for barcodes, prices, product names, etc.

Figure 7-1: CLARiSOFT Sample Database
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Linking fields to the CLARiSOFT Database
The following example shows how to link two fields in a message (Price and Use-
by Date) to the corresponding data in the underlying CLARiSOFT sample 
database.

Designing the Image Template
In this example, we will use an existing CIFF file supplied with CLARiSOFT.

1 Open CLARiSOFT.

2 Open the file ‘Outer Primary Example2.ciff’ that is supplied with 
CLARiSOFT, from the default CIFF directory (typically 
C:\CLARICOMDATA). The following image will be displayed.

3 We will now delete the fields from this template to give us an empty file in 
which we will build our message. Select all the fields in the image design 
area and click Delete in the tool bar or use the Delete button on the keyboard.

4 In the following steps, we will create two static text fields displaying the text 
‘Use By’ and ‘Price’. This text will remain the same for all jobs using this 
template.

Figure 7-2: Open File
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5 Click on the Text tool in the tool Box. Click on the Image Design Area where 
this field is to be placed. The Text Properties dialog box appears.

6 In the Default Text box, enter the text ‘Use By’. Leave the other parameters as 
shown below.

7 In the General tab, name this field as ‘txtUseBy’. Click OK.

8 Now we have the first static field in the image design area. Drag and arrange 
this field to a suitable place in the design area.

Figure 7-3: Text Properties- Text

Figure 7-4: Static Field
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9 Create a second text field following the steps from Step 5 to Step 7 with a 
default text ‘Price’ and a field name ‘txtPrice’.

10 The second static text field is created. Drag and place this field under the first 
static text field ‘Use By’ and align properly.

11 Now we will create two fields which, when linked to the database, will 
contain the data from the CLARiSOFT database relating to the selected job. 
See later for details on how to select a job.

Click on the Date tool in the tool box and place it to the right side of the text 
‘Use By’. The Date Properties dialog box appears.

Figure 7-5: Second Static Text Field
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12 Select the Date Format as ‘dd/MM/yy’. Leave the other parameters as shown 
below. 

13 In the General tab, name this field as ‘dtUseBy’.

Figure 7-6: Date Properties
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14 Click OK. The date field is created. Note that this is showing the current date, 
until we link this to the CLARiSOFT database.

15 Click on the Price tool in the tool box and place it to the right side of the text 
‘Price’. The Price Properties dialog box appears. Select Fixed Text from the 
Type drop down list. Enter 10.00 in Default Text. Leave other parameters as 
shown below. 

Figure 7-7: Date Field Generated

Figure 7-8: Price Properties



7-8     Linking fields to the CLARiSOFT Database Rev AA

CLARiSOFT User Manual

16 In the General tab, name this field as ‘prcItemPrice’.

17 Click OK. The price field is created in the image design area. Note that this is 
a static field, until we link this to the CLARiSOFT database.

Linking the CIFF to Jobs in the Database
A CIFF file can be used by multiple jobs in the database thus allowing different 
data for different jobs. CLARiSOFT needs to know which CIFF file should be 
used with the job and this is performed by storing the name of the associated CIFF 
file within the job record in the CLARiSOFT database. The CLARiSOFT 
database uses a specific field to store the name of the CIFF, by default this is 
called the ‘CIFFReference’.

In certain instances, multiple CIFF files may be used per job i.e. when running 
CLARiNET and multiple coders are used on the line for the same job. When the 
job is selected the correct CIFF file is download to each coder. This is supported 
by storing the name of each CIFF in a different field in the job record. Up to 5 
different CIFF references can be stored and used within a job.

It is therefore important, when creating a CIFF that is linked to a job in a 
database, to correctly specify which CIFF reference field in the database 
should be used to store the name of the CIFF file.

Figure 7-9: Message Template
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This linking is performed as follows. 

In CLARiSOFT, navigate to Tools > Options > Printing. Under Printing Setup, 
select CIFF Reference from the drop down list. This is the reference field for the 
primary CIFF file. The other fields are used if there is a second and third coder in 
use in the job.

Now, we will link the date field and price field to the CLARiSOFT database. Note 
that the CLARiSOFT sample database already contains jobs assigned to this 
template and hence why this particular CIFF file was used for this example. When 
we link these fields to the database, CLARiSOFT searches for jobs containing this 
CIFF file name in the CIFFReference column of the database and returns the 
values to be used by the ‘dtUseBy’ and ‘prcItemPrice’ fields. Note that these data 
fields already exist in the sample database.

Figure 7-10: CLARiSOFT Options
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18 Double click on the price field ‘prcItemPrice’ that was previously created. 
The Price Properties dialog box appears.

19 From the Type drop down list, select CLARiSOFT Database. This directs 
CLARiSOFT to fetch the price data which corresponds to this job from the 
database.

20 From the Field to Use drop down list, select Price, which is the name of the 
field containing the data from the database.

Figure 7-11: Price Properties
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21 Click OK. The ‘prcItemPrice’ field turns green indicating that it is linked to a 
database.

22 Now we will link the date field to the underlying data in the database.

Note: Linking date fields to underlying data in the database is performed 
differently to other types of linked fields.

23 Double click on the date field ‘dtUseBy’ that was previously created. The 
Date Properties dialog box appears.

24 From the Date Type drop down list, select Calculated Date.

25 Click New in the Date Calculation Manager dialog box.

Figure 7-12: Linked Price Value Field
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26 In the Calculation Name box, enter the name ‘calcUseBy’.

27 From the Source drop down list, select Date Offset from Claricom Database. 
Leave the Default Offset as ‘0’, as the offset date will be calculated from the 
use by date values present in the Database.

28 From the Database Field drop down list, select ‘UseByOffset’.This is the 
name of the field in the database that we wish to link to. The date for each job 
will be calculated by adding the offset dates extracted from the database to 
the date specified in the Reference date drop down list (see Figure 7-13).

29 Click OK. The calculation name appears in the Date Calculation Manager 
dialog box.

Figure 7-13: Date Calculation Properties

Figure 7-14: Date Calculation Manager
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30 Click OK to close the Date Calculation Manager dialog box. Click OK to 
close the Date properties dialog box. The ‘Use By Date’ field in the image 
design area changes its color to green, indicating that it is linked to a 
database.

31 Both the fields have been now linked to the database. Save the image.

Note: It is also possible to link directly to an explicit date in the database. To 
do this, choose the 'pre-calculated date from CLARiCOM Database' option 
from the 'Source' drop down list in the ‘Date Calculation Properties’ dialog 
box.

Figure 7-15: Linked Use By date field
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32 Make sure that the Database Viewer Toolbar is visible by selecting View > 
Database Viewer.

The Database Viewer is enabled after the image is saved. There are two jobs 
in the database related to this CIFF reference. These job codes are listed in 
the Database Viewer drop down list.

Note: The database viewer will only function correctly if the current CIFF 
file has been saved and matches a CIFF file name stored in the database.

Figure 7-16: Database Viewer

Database 
Viewer
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33 Select a job that references this CIFF file by selecting the first job code from 
the drop down list in the database viewer. Both the linked data fields, the 
‘dtUseBy’ and the ‘prcItemPrice’ fields, are updated to reflect the 
corresponding values from the selected job.

Note: The price values defined in the database are 50 and 35 respectively. 
Since we selected the format of the currency to two decimal places, 
CLARiSOFT considers the last two digits in the database as the decimal 
values. Ensure that the format defined in the properties dialog box is the same 
as the format defined in the database.

Figure 7-17: Job Code 1
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34 Scroll between the records in the database using the left and right arrows in 
the job selector or select a specific record from the drop down list. Click on 
the right arrow of the ‘job selector’. The next job in the database that 
references this CIFF file is displayed and the linked field values are updated. 
The jobs are displayed in the drop down list sorted in ascending job code 
order.The ‘record number’ indicates that this is the second job out of two 
available jobs in the database that references this CIFF file.

Figure 7-18: Second Job
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Open Database Connectivity (ODBC)
Similar to its ability to work with its own database, CLARiSOFT can also use any 
database that is ODBC compliant. Once CLARiSOFT is linked to the external 
ODBC database, the data fields can be managed in the same way.

Linking CLARiSOFT to an external ODBC database
1 Open CLARiSOFT.

2 Navigate to Tools > Options > Database Setup.

3 Select User Specified Data Source under Where is my Database?.

Figure 7-19: Linking to External Database
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4 Click Select. The Data Link Properties dialog box appears.

Note: The content of the data link property list is dependent on the drivers 
installed on the machine running CLARiSOFT. The following screens are 
dependent on the type of external ODBC database that is being connected.

5 Select the required Database provider from the list. This needs to match the 
ODBC database that will be accessed. Click Next.

Figure 7-20: Data Link Properties - Provider

Figure 7-21: Data Link Properties- Connection
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6 Insert the connection details required to access the database on this screen.

7 Click on the Test Connection button. The message Test Connection 
Succeeded appears.

8 Click OK. The database link will appear in the CLARiSOFT Options dialog 
box. Click OK.

9 Select the required table containing job data from the drop down list Table 
Containing Index Fields.

10 As the column names in the external ODBC database may differ from 
CLARiSOFT database, perform mapping of columns by selecting the fields 
in the database from the drop down lists under Which field in the database 
does this map to?.

11 Click OK.

Figure 7-22: Options
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8Advanced Message 
Design

CLARiSOFT offers powerful message design features to increase assurance that 
printed codes are correct by minimizing, or restricting, the amount of 
operator-entered information. This chapter contains some advanced message 
design examples to demonstrate how to use these features.

User Entered Field- Pick List
To increase Code Assurance, it may be beneficial for an operator to select an entry 
from a previously determined list. In the following example, we will create a pick 
list in CLARiSOFT. The operator, during job selection, will be prompted to select 
an option from the list according to the product being coded.

We will create two fields: the first a fixed text field stating ‘Factory Location’ and 
the second a pick list from which the operator will pick the factory location during 
job setup. 

1 Open CLARiSOFT.

2 Click File > New to create a new image. Select the coder and image / size 
options as shown in Figure 8-1. 

3 Click OK.

Figure 8-1: Select the Coder
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4 Click on the Text tool in the toolbox. A text field is added to the image and the 
Text Properties dialog box appears.

5 In the Default Text box, enter the text ‘Factory Location’.

6 In the General tab, name this text field ‘txtFacLoc’.

7 Click OK. The first text field is displayed in the image design area.

8 Create another text field which will be modified to supply the operator with a 
list of factory locations such as ‘London’, ‘Texas’ and ‘Tokyo’.

Click on the Text tool in the toolbox. The Text Properties dialog box appears.

Figure 8-2: Text Field-Factory Location
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9 Select User List from the Type drop down list. Leave the other parameters as 
shown in Figure 8-3.

Figure 8-3: Text Properties-User List
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10 Click on the List button. The User List dialog box appears.

11 Use this dialog box to enter the items for the pick list. Select Default Text in 
the list box under Data and click Edit.

12 The Enter User List Text dialog box appears. Enter the text ‘London’ and 
click OK.

Figure 8-4: User List

Figure 8-5: User List Text- London
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13 The User List dialog box displays the first location in the list.

14 Click the Add button. The Enter User List Text dialog box appears. Enter the 
text ‘Texas’ and click OK.

15 The User List dialog box displays the second location in the list.

16 Click on Add button and enter ‘Tokyo’ in the Enter User List Text dialog box 
and click OK.

Figure 8-6: User List
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17 The User List dialog box has now all three locations. Click OK.

Figure 8-7: Complete User List 
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18 In the Text Properties dialog box, the default text is changed to ‘London’; the 
first entry in the list. The text appears in the Print Preview also.

In the Prompt Message box, enter the text ‘Select the Factory’. This message 
will be displayed during job selection.

19 In the General tab, name this field as ‘FacLoc’.

Figure 8-8: Text Properties - Updated
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20 Click OK. The image design area will appear as shown in Figure 8-9.

21 Save the file as ‘Pick List Example.ciff’.

22 Click File > Print. 

23 Select Download under Image Options.

24 Select Current Image under Print What. 

25 The Job Selection Confirmation dialog box appears. Verify that the preview 
is correct and click OK.

Figure 8-9: Image Design Area-Updated

Figure 8-10: Job Selection Confirmation
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26 The job download starts. CLARiSOFT displays the progress. Click Close 
when the download is complete.

27 At the coder’s user interface, touch the Job button. Select the job Pick List 
Example and touch OK.

Figure 8-11: Progress

Figure 8-12: Job Select
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28 The prompt message created in CLARiSOFT appears. Touch Edit to select 
the factory from the pick list.

29 The list of factories created in CLARiSOFT appears. Select Tokyo from the 
list and touch OK. 

Figure 8-13: Prompt Message during Job Selection

Figure 8-14: Select the Factory
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30 A tick mark appears showing that this user entered field has been completed. 
The factory location is changed to ‘Tokyo’ in the preview.

31 Touch OK. The print preview is displayed. 

32 Touch OK. The job is ready for printing.

Figure 8-15: Job Select

Figure 8-16: Job Preview
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Advanced Merge Fields
In this example, we will create a merge field by concatenating two complete fields 
and a part of a third field. Refer to “Create a Merge Field” on page 4-21 for basic 
information on creating merge fields.

1 Open the file ‘Pick List Example.ciff’ created in section “User Entered Field- 
Pick List” on page 8-1.

2 In this example we will add a batch code to this message which will be in the 
format 

‘Batch Code : YYJulXX’ where ‘YY’ is the current year, ‘Jul’ is the Julian 
Date’ and ‘XX’ is the first two letters of the factory location.

We will create two new date fields ‘year’ and ‘julian date’ and concatenate 
them to the first two letters of the factory location.

3 Click on the Date tool in the toolbox. The Date Properties dialog box 
appears. Select the date format as ‘yy’.

4 In the General tab, name this field as ‘Year’ and select Non-Printed under 
Features.

Figure 8-17: Text Properties
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5 Click OK. Drag and place this field off the image area to the right, in the 
orange area (see Figure 8-19).

6 Click on the Date tool. The Date Properties dialog box appears. Select date 
format ‘JulDayz(060)’.

7 In the General tab, name this field as ‘Julian’ and select Non-Printed under 
Features.

8 Click OK. Drag and place this field off the image area to the right, in the 
orange area. The main screen should look like:

9 Create a text field with fixed text ‘Batch Code’ and name it as 
‘txtBatchCode’. Place this field below the ‘txtFacLoc’ field.

Figure 8-18: Text Properties

Figure 8-19: Image Design Area
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10 Create the merge field as follows. Click on the Text tool in the toolbox and 
place the text on the image design area to the right of the ‘txtBatchCode’ 
field.

11 In the Text Properties dialog box, select Merge Field from the Type drop 
down list. Click on Merge button.

12 The Field Merger dialog box appears. Click on each of the ‘Year’, ‘Julian’ 
and ‘Facloc’ fields in turn and click Add ->. Arrange the fields in order as 
shown in Figure 8-20 using the Move Up and Move Down buttons.

Concatenate the three fields together as follows. The text we want to print is 
‘YYJulXX’. The year and Julian Date fields are to be printed fully, but only 
the first two characters of the factory location field.

Select the field ‘FacLoc’ within Selected Fields list box. In the Selection box, 
select the first two letters of the factory location as shown below. A preview 
of the merged text appears in the Field Merger dialog box (see Figure 8-21).

Figure 8-20: Field Merger

Figure 8-21: Field Merger Preview
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13 Click OK to close Field Merger dialog box. Click OK to close the Text 
Properties dialog box.

14 The merged field appears in the image design area.

Advanced Date Fields

Date Offsets using Calculation Manager
The following example shows how to setup date offsets using CLARiSOFT 
calculation manager. 

1 Open CLARiSOFT.

2 Click File > New. Select the Coder as Videojet 1650 and set the Select 
Format as 12-high.

3 Click on the Text tool in the toolbox to create a text label ‘Use By’. Call the 
field ‘txtUseBy’.

4 Click OK to close the Text Properties dialog box. The image design area 
displays the text.

Figure 8-22: Merged Field using a part of text field
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5 Click on the Date tool in the toolbox. The Date Properties dialog box 
appears. Note that the current date appears, for the example it is 21/10/2013.

6 Select Calculated Date from the Date Type drop down list and click Calc 
Manager. Click New in the Date Calculation Manager dialog box.

7 Set an offset of 60 days from the current date. Enter the calculation name 
‘calcP+60’ under Calculation Name. Select Current Date from the Reference 
Date drop down list and Within Image from the Source drop down list. This 
means the date calculation will be based on the current date.

Figure 8-23: Date Properties
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8 Enter the Default Offset as ‘60’ and Units as ‘days’.

9 Click OK to exit the Date Calculation Properties dialog box. Click OK to exit 
the Date Calculation Manager dialog box and click OK to exit the Date 
Properties dialog box.

10 The offset date is displayed in the image design area. This date is 60 days 
after the current date (21/10/2013 in this example).

11 Save this file as ‘advanced date field example.ciff’.

Figure 8-24: Date Calculation Properties

Figure 8-25: Updated Offset Date
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User Concessions
User concession allows you to limit a range of dates that the operator can select 
from during job selection.

1 Open the file ‘advanced date field example.ciff’.

2 Double click on the ‘dtUseBy’ field. The Date Properties dialog box appears. 

3 Click Calc Manager. The Date Calculation Manager dialog box appears.

4 Select ‘calcP+60’ in the Supported Date Calculations box and click Edit. The 
Date Calculation Properties dialog box appears.

5 Click on the User Concessions tab. Click the check box Allow User to 
change.

6 Enter the prompt message ‘Please Enter the Date’. 

7 Set the Minimum Offset Units as Days. Set the Minimum Offset as -10 and 
Maximum Offset as 10.

By setting the minimum and maximum offsets, we allow the operator to only 
select a date in the range of 10 days before or after the calculated date.

8 Click OK. Click OK to close the Date Calculation Manager dialog box and 
click OK to close the Date Properties dialog box.

Figure 8-26: Date Calculation Properties
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9 The image design area appears as shown below.

10 Save the file.

11 Click File > Print. 

12 Select Download under Image Options.

13 Select Current Image under Print What. 

14 The Job Selection Confirmation dialog box appears. Verify that the preview 
is correct and click OK.

15 The job download starts. CLARiSOFT displays the progress. Click Close 
when the download is complete.

Figure 8-27: Updated Offset Date
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16 At the coder’s user interface, touch the Job button.The updated job is shown 
in the job select list.

17 Select the job and touch OK.

18 The prompt message created in CLARiSOFT appears.

Figure 8-28: Job Select

Figure 8-29: Prompt Message
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19 Select the prompt message and touch Edit. The calendar Page appears.The 
only dates selectable are those that will fall within the range of -10 to +10 
days of the calculated offset date.

20 Select the required date.

21 Touch OK. 

Figure 8-30: User Concession example of selectable dates

Figure 8-31: Select the Required Date
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22 A tick mark appears with the prompt message. The preview is updated to 
reflect the selected date. Touch OK.

23 The print preview is displayed. Touch OK.

24 The ‘use by date’ is updated and the job is ready for printing.

Figure 8-32: Updated Date Field

Figure 8-33: User Concession Example Preview
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Date Avoidance
Date Avoidance blocks specific dates from being selected or calculated.

The following example explains how to set up ‘Avoidance Dates’ using 
CLARiSOFT and how the ‘Avoidance Dates’ are managed during job selection. 
We will use the CIFF file from the previous example. 

Note: The file ‘advance date field example.ciff ’ now has the date field set to a 
calculated offset of ‘60’ days, but the operator can select a date from ±10 days 
from the calculated date. In this example, we will block 25th December from being 
selected.

1 Open the file ‘advanced date field example.ciff’.

2 Double click on the ‘dtUseBy’ field. The Date Properties dialog box appears. 

3 The calculation name ‘calcP+60’ is present under Calculation to Use. Click 
Calc Manager. The Date Calculation Manager dialog box appears.

4 Select ‘calcP+60’ under Supported Date Calculations box and click Edit. The 
Date Calculation Properties dialog box appears.

5 Click the Calendar Rules tab.

6 Click the Add button to the right of Avoidance Dates.

Figure 8-34: Calendar Rules-Avoidance
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7 Set the Date to avoid to ‘25’ and ‘December’.

8 Click OK. Confirm the date set appears in the Avoidance Date data of the 
Date Calculation Properties dialog box.

9 Click OK to close the Date Calculation Properties dialog box and click OK 
to close Date Calculation Manager dialog box. Click OK to close the Date 
Properties dialog box.

10 Save the file.

11 Click File > Print.

12 Select Download under Image Options.

13 Select Current Image under Print What. 

14 The Job Selection Confirmation dialog box appears. Verify that the preview 
is correct and click OK.

15 The job download starts. CLARiSOFT displays the progress. Click Close 
when the download is complete.

16 At the coder’s user interface, touch the Job button.The updated job is shown 
in the job select list.

17 Select the job and touch OK.

Figure 8-35: Calendar Rules-Avoidance Date

Figure 8-36: Job Select
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18 The prompt message created in CLARiSOFT appears.

19 Touch Edit. The calendar page appears. Note that the date ‘25th December’ is 
in grey and cannot be selected.

Date Rounding
Allows the date fields to be rounded in a message to a particular day of the week, 
or round to a particular day of the month. We will use the CIFF file from the 
previous example to demonstrate how to round a selected or calculated date upto 
the next Monday.

1 Open the file ‘advanced date field example.ciff’.

Figure 8-37: Prompt Message

Figure 8-38: Avoidance Date
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2 Double click on the ‘dtUseBy’ field. The Date Properties dialog box appears. 

3 The calculation name ‘calcP+60’ is present under Calculation to Use. Click 
Calc Manager. The Date Calculation Manager dialog box appears.

4 Select ‘calcP+60’ under Supported Date Calculations box and click Edit.The 
Date Calculation Properties dialog box appears.

5 Click on the Rounding tab.

6 Select Round Up from the Mode drop down list to round to the next Monday.

7 Select Weekly from the Frequency drop down list.

8 Select Monday from the Interval drop down list.

9 Click OK to close the window. Click OK to close the Date Calculation 
Manager dialog box and click OK to close the Date Properties dialog box.

10 Save the file.

11 Click File > Print.

12 Select Download under Image Options.

13 Select Current Image under Print What. 

14 The Job Selection Confirmation dialog box appears. Verify that the preview 
is correct and click OK.

15 The job download starts. CLARiSOFT displays the progress. Click Close 
when the download is complete.

Figure 8-39: Rounding
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16 At the coder’s user interface, touch the Job button. The updated job is shown 
in the job select list.

17 Select the job and touch OK.

18 The prompt message created in CLARiSOFT appears.

Figure 8-40: Job Select

Figure 8-41: Prompt Message



8-28     Advanced Date Fields Rev AA

CLARiSOFT User Manual

19 Touch Edit. The calendar page appears. Only Mondays are now available for 
selection.

Calendar Rules
CLARiSOFT enables the user to define the rules to control dates that are 
calculated, selected and used.

The following example explains how to set up Calendar Rules in CLARiSOFT. 
We will use a date field linked to the database in a sample file, and then apply 
calendar rules to the date field to avoid any particular dates.

1 Open CLARiSOFT. 

2 Click Tools > Options.

3 In the Database Setup tab, under Where is my Database? select CLARiSOFT 
database.

4 Click Browse and select ‘CLARiSOFT-Sample.mdb’ from the default 
directory. Click OK.

5 Open the file ‘inner primary example1.ciff’ from the default directory.

6 Save this file in another location (File > Save As...) without changing the 
name of the file. If the file name is changed, the database will no longer link 
to the CIFF file.

Figure 8-42: Selectable Dates from ‘Date Rounding Example’
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7 From the Database Viewer, select the job ‘D004IRL’. The image design area 
is shown in Figure 8-43. The offset date calculated from the database is 16th 
November. We will create a calendar rule to automatically re-calculate the 
date to be one day before the original date.

8 Double click on the date field in the image design area. The Date Properties 
dialog box appears.

9 The calculation name ‘USEBY’ is present under Calculation to Use. Click 
Calc Manager. The Date Calculation Manager dialog box appears

10 Select ‘USEBY’ under Supported Date Calculations box and click Edit. The 
Date Calculation Properties dialog box appears.

Figure 8-43: Job Code D004IRL
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11 Click on the Calendar Rules tab.

12 Click the Add button to the right of Calendar Rules.

13 Select the Date to Change to ‘16’ and ‘November’.

14 Set the Offset to -1 days. Note that the Preview displays the date ‘15 
November’.

15 Click OK. The calendar rule is added in the box. 

Figure 8-44: Date Calculation Properties: Calendar Rules

Figure 8-45: Set Calendar Rule



Rev AA Advanced Date Fields     8-31

CLARiSOFT User Manual

If necessary, multiple rules can be added following similar steps.

16 We will now allow the user to change the dates using User Concessions. 
Click on the User Concessions tab. 

17 Click the check box Allow User to Change. Insert the text ‘Enter the Date’ in 
the Prompt Message text box. 

Figure 8-46: Calendar Rule Added
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18 Select Days from the Minimum Offset Units drop down list and set the 
Minimum Offset as -3 and Maximum offset as +3.

19 Click OK to close the dialog box. Click OK to close the Date Calculation 
Manager dialog box and click OK to close the Date Properties dialog box.

20 The Image Design Area is updated to reflect the calendar rules applied.

21 Save the file.

Figure 8-47: Set User Concession

Figure 8-48: Image Design Area
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22 Click File > Print. 

23 Select Download and Select under Image Options. This will prompt for the 
variable information required by the job AT THE PC, and then download it to 
the coder as fixed text. If the job is subsequently selected at the coder, the 
variable information will not be prompted.

24 Click Database Record under Print What to tell CLARiSOFT to print a job 
from the CLARiSOFT database. 

25 The Select Job Code dialog box appears.

Figure 8-49: Print

Figure 8-50: Select Job Code



8-34     Advanced Date Fields Rev AA

CLARiSOFT User Manual

26 In the following example we will print job D004IRL from the database. View 
the associated record in CLARiSOFT database manager (see Figure 8-51).

27 Following the database record, double click on Mega Market to select Job 
Code 1.

28 From the Job Code 2 list, select Rice.

29 From the Job Code 3 list, select 500g.

Figure 8-51: Sample Database- Job Code D004IRL

Figure 8-52: Select Job Code ‘2’
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30 From the UniqueJobCode list, select D004IRL.

31 Click Finish. The Variable Data Entry dialog box appears.

32 Double click on the prompt message. The calendar page is displayed.

Figure 8-53: Select ‘UniqueJobCode’

Figure 8-54: Variable Data Entry

Figure 8-55: User-entered Date Offset Field- Calendar
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33 Select the date ‘16 November’. Click OK. The following message is 
displayed.

34 Click OK. The Job Selection Confirmation dialog box appears.The date in the 
preview is changed to 15 November based on the calendar rule set. 

35 Click OK to close the preview. 

36 The job download starts. CLARiSOFT displays the progress. Click Close 
when the download is complete.

Figure 8-56: Calendar Rule Warning

Figure 8-57: Job Selection Confirmation
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37 The selected job appears in the home page of the coder’s user interface.

Automated Management of Avoidance Dates
CLARiSOFT and the coder manage both the avoidance date and calendar rules 
when a date is selected automatically.

38 This is an example of the image design area within CLARiSOFT when an 
automatically generated date does not conform to the calendar rules. The 
invalid field changes to red. Place the cursor over the date field and the cause 
of the error is shown.

Figure 8-58: Home Page

Figure 8-59: Avoidance Date in Image Design Area
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39 If the warning is ignored and the job is downloaded to the coder, the job 
preview screen will display no date. 

40 If the job is downloaded to the coder, the user interface displays the fault 
message FAULT (E1243) Invalid Job File - Avoidance Date.

Figure 8-60: Job Selection Confirmation

Figure 8-61: Fault Display
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41 Touch on the fault display in the status bar. Touch the ‘>’ button to the right 
of the fault details. 

42 A description of the fault is displayed.

43 Follow the instructions given in the description to clear the fault. Open 
CLARiSOFT and make the required changes to the message to avoid the 
‘avoidance date’.

Figure 8-62: Fault List

Figure 8-63: Fault Description
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Arabic Dates
The following example shows the procedure to create and select dates in the user 
interface language and print it in Arabic characters.

1 Open CLARiSOFT.

2 Select the Coder as Videojet 1650 and Select Format as ‘12-high’.

3 Click on the Text tool in the toolbox. The Text Properties dialog box appears.

4 Select Fixed Text from the Type drop down list and enter the text ‘Use By’ in 
the default text box. 

5 In the Font tab, select the font as 12-high international.

6 In the General tab, name this field as ‘txtUseBy’ and click OK.

7 Click on the Date tool in the toolbox. The Date Properties dialog box 
appears.

8 Select User Entered Date from the Date Type drop down list. 

9 Set the Minimum Offset as ‘zero’ days and Maximum Offset as ‘3’ days.

10 Enter the Prompt Message as ‘Select the Date’.

11 In the Font tab, select the font as 12-high international.

12 In the General tab, name this field as ‘dtUseBy’.

Figure 8-64: Date Properties
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13 Click OK. The image design area appears as follows.

14 To change the date so that it appears in Arabic, double click on the date field 
and click on the General tab on the Date Properties dialog box.

15 From the drop down list under Encrypted Field, select 
CLARiTY.Encryption.Arabic.

16 Click on the Text tab and select the correct regional language from the 
Language drop down list. (Arabic - Egypt is selected for the example).

Figure 8-65: Image Design Area

Figure 8-66: Encryption
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17 Click OK. The image design area displays the date field in Arabic.

18 Save the file as ‘arabic example.ciff’.

19 Click File > Print.

20 Select Download under Image Options.

21 Select Current Image under Print What. 

22 The Job Selection Confirmation dialog box appears. Verify that the preview 
is correct and click OK.

23 The job download starts. CLARiSOFT displays the progress. Click Close 
when the download is complete.

Figure 8-67: Encryption



Rev AA Arabic Dates     8-43

CLARiSOFT User Manual

24 At the coder’s user interface, touch the Job button. Select the job ‘arabic 
example’ and touch OK.

25 The prompt message created in CLARiSOFT appears. Touch Edit.

Figure 8-68: Job Select

Figure 8-69: Prompt Message
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26 The calendar in the standard Gregorian format appears. Select the required 
date (19 in this example) and touch OK.

27 A tick mark appears with the prompt message. The preview is updated to 
reflect the selected date. Touch OK. 

28 The print preview is displayed with the selected date in Arabic. Touch OK. 

29 The job is ready to be printed with Arabic dates.

Figure 8-70: Select the Date

Figure 8-71: Job Preview
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Transmitted Fields
Transmitted fields are unique string commands that are transmitted to the RS232 
serial port of the coder where available.

The data can be transmitted in two different modes which is setup in CLARiTY 
Configuration Manager for the coder:

• Each Print (data will be sent to RS232 serial port each time the job is printed).

• Every Job select (data will be sent to RS232 serial port each time the job is 
selected).

The data can then be used as required. For example, the job weight can be sent to 
a checkweigher to validate that the weight printed on the product is correct or to a 
validation scanner to confirm that the barcode printed matches the input data.

The following example creates a transmitted field for a Microscan Validation 
Scanner.

Note: Only one transmitted field is allowed per job.

1 Open CLARiSOFT.

2 Click File > New to create a new image. Select the coder as VJ2360 and the 
image width as ‘350 mm’.

3 Save this file as ‘Secondary Example2.ciff’ in another location to avoid 
overwriting the existing sample CIFF file. Do not change the name, as this 
CIFF File is referenced in the database.

4 The first field in the transmitted field represents the ‘Scanner Control 
Header’ that tells the specific microscan validation scanner to prepare to 
receive barcode data to store and read for that message. Click on the Text tool 
in the toolbox and click on the image design area.The Text Properties dialog 
box appears.

5 In the Default Text box, enter the header syntax ‘<K231,1,’.

6 Set the font size to ‘25’ in Font tab.

7 In the General tab, name this field as ‘Header’. Select Non-Printed under 
Features. Click OK.
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8 Click OK. Move the text field off the image design area as shown below.

9 The second field will represent the control trailer that the scanner understands 
as the end of the serial string command. Create another Text Field having 
default text ‘>’ and font size 25. Name this field ‘Trailer’ and set the feature 
as Non-Printed in the General tab. Click OK.

10 Move this field off the image as shown below.

11 The third field represents the data that the barcode will contain. It will also 
form the part of the serial string command between the header and trailer that 
tells the scanner the data that the barcode should contain for the duration of 
the printed job.

12 Create another Text Field by selecting CLARiSOFT Database from the Text 
Type drop down list. Select Secondary Case Code from the Field to Use drop 
down list. This field in the database contains the numbers for shipping 
container code for the secondary job.

13 Name this field ‘Data’ in the General tab and select Non-Printed under 
Features. Click OK.

Figure 8-72: Header Field

Figure 8-73: Trailer Field



Rev AA Transmitted Fields     8-47

CLARiSOFT User Manual

14 Move the field off the image design area as shown below.

15 Now we will merge the three fields we created to form the complete serial 
string command. This will be the ‘Transmitted Field’ that is sent to the 
scanner.

16 Create a Text Field and select Merged Field from the Type drop down list in 
the Text Properties dialog box. 

17 Click Merge. In the Field Merger dialog box, select all the three fields we 
created and click OK.

Figure 8-74: Data Field

Figure 8-75: Merged Field
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18 In the General tab, under Features, click Transmitted Field. This will activate 
this field and its contents as the output from the printer through its serial port 
to the scanner once this message is loaded in the printer.

19 Click OK. Move this field off the image design area as shown below.

20 The next field is the actual barcode that the printer will print. Click on the 
Secondary Barcode tool in the toolbox and click on the image design area.

21 Select ITF from the list of Secondary Barcodes. Click OK.

22 In the ITF Properties dialog box, select Merge Field from the Type drop 
down list.

Figure 8-76: Transmitted Field Setting

Figure 8-77: Transmitted Field
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23 Click Merge.

24 Select the field Data from the available fields and click Add.

25 Click OK.

26 Choose the Magnification, Human Readable Style and Barcode Features that 
match the standard symbology. Uncheck the Automatically Calculate Check 
Digit box.

27 Click OK.

28 Position the bar code in the image design area.

29 Save the file as ‘Transmitted Field example.ciff’.

The printer will send the transmitted field to the scanner when the job is loaded. 
The scanner then matches the code that is printed with the transmitted field and 
ensures code matching.

Note that the coder will need to be correctly configured to send the transmitted 
field on the correct serial port number and required serial port parameters. Refer 
to the coder manual for details.

Figure 8-78: Barcode Data
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9CLARiSOFT Print 
Manager

CLARiSOFT Print Manager is a standalone application that enables an operator to 
select an existing image file and download it to a coder without the ability to 
change the message structure / content. This avoids the risk of accidental changes 
to the images or templates in CLARiSOFT.

The CLARiSOFT Print Manager supports user-entered data and database fields if 
the job includes them.

Starting CLARiSOFT Print Manager
Note: CLARiSOFT Print Manager and CLARiSOFT cannot run in parallel on the 
same PC. Close CLARiSOFT before opening CLARiSOFT Print Manager.

Open ‘CLARiSOFT Print Manager’.The following screen is displayed.

CLARiSOFT Print Manager Tool Bar

Tool Description

Log in: Limits access to authorised users.

Table 9-1: CLARiSOFT Print Manager Tool Bar

Figure 9-1: CLARiSOFT Print Manager
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Next Job: Selects the next job for printing or downloading to the 
coder.

Settings: 
 1. Database Setup: Allows the user to specify the source: 

CLARiSOFT Database, or an External ODBC Database.
 2. Language Selection: Selects the User Interface Language.

Printer:
 1. Printing: Selects a coder to connect to the Print Manager.
 2. Communications: Allows the user to enter the network com-

munication details.
 3. General: Allows the user to select the Job selection method, 

set the print quality, select the Job selection functionality 
and set the CIFF Reference field.

 4. Print Mode: Allows the user to set the print mode (Batch or 
Sequence).

 5. SSCC: Allows the user to configure SSCC information for 
valid coders only.

History: Allows the user to view the history of jobs downloaded 
for printing and changes to the CLARiSOFT Print Manager.

About: Allows the user to view the software version number.

Tool Description

Table 9-1: CLARiSOFT Print Manager Tool Bar
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Configuring Print Manager 

Printing a Job using Print Manager and CIFF files
The following procedure explains how to print a job using the CLARiSOFT Print 
Manager. We will use a Videojet 1650 coder to print the job.

1 Click the Log in tool from the toolbar.

2 Enter the Username and Password supplied by your administrator and click 
Login.

Figure 9-2: LogIn
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3 Click the Settings button to configure the database source that CLARiSOFT 
Print Manager uses. Under Where is my Database?, select CLARiSOFT 
Database, to link to the CLARiSOFT database, if required. Select User 
Specified Data Source, if the database is an external ODBC one.

4 Click the Language Selection tab and click Change tab to change the 
language if required.

5 Click OK.

Figure 9-3: Database Setup
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6 Select the Coder that will be used for printing. Click the Printer button. 
Under Select Printer option, select the required coder model. In this example, 
as we are using VJ1650, select Videojet > CLARiTY > VJ1650.

7 Using the Browse button, select the working directory where the CIFF files 
are stored. CLARiSOFT Print Manager will use this location to load the job 
files.

Figure 9-4: Select Printer
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8 Click on Communications tab.

9 If the coder is connected via serial port, enter the port number, baud rate and 
other details as required.

If the printer is connected using a TCP/IP network, enter the IP address of the 
printer that is being connected. Enter the port number (For further 
information, refer to your Coder Documentation).

Figure 9-5: Communications
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10 To configure the method of job selection, click on the General tab and select 
the Job selection method as File Based. Select the Job Selection 
Functionality as Download without selecting.

11 Click OK.

12 Click the Next Job button. CLARiSOFT Print Manager displays the 
Connecting dialog box.

13 Once the connection is established, CLARiSOFT Print Manager prompts the 
job to be selected from the working directory. Select the job ‘Pick List 
Example.ciff’ and click Open.

Figure 9-6: General Settings

Figure 9-7: Connection Status
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14 The Job Selection Confirmation dialog box appears. Verify that the preview 
is correct and click OK.

15 The job download starts. CLARiSOFT Print Manager displays the progress. 
Click Close when the download is complete.

Figure 9-8: Job Selection Confirmation

Figure 9-9: Progress
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16 At the coder’s user interface, touch the Job button. Select the job Pick List 
Example and touch OK.

17 The prompt message defined in CLARiSOFT appears. Touch Edit to select 
the factory from the pick list.

Figure 9-10: Job Select

Figure 9-11: Prompt Message during Job Selection
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18 The list of factories created in CLARiSOFT appears. Select Tokyo from the 
list and touch OK. 

19 A tick mark appears showing that this user entered field has been completed. 
The factory location is changed to ‘Tokyo’ in the preview.

Figure 9-12: Select the Factory

Figure 9-13: Job Select
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20 Touch OK. The print preview is displayed. 

21 Touch OK. The job is ready for printing.

Printing a Job Linked to a Database
CLARiSOFT Print Manager can be used to print CIFF files where the data are 
connected to a database.

In this example, we will print a sample CIFF file (‘Inner Primary Example1.ciff’) 
supplied with CLARiSOFT.

1 Click the Log in tool from the toolbar.

2 Enter the Username and Password supplied by your administrator and click 
Login.

3 Click the Settings button to configure the database source that CLARiSOFT 
Print Manager uses. Under Where is my Database?, select CLARiSOFT 
Database, to link to the CLARiSOFT database. Select User Specified Data 
Source, if the database is an external ODBC one.

Figure 9-14: Job Preview
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4 Click Browse and select CLARiSOFT - sample.mdb from the default directory 
or choose the relevant ODBC connection to use (refer to “Linking 
CLARiSOFT to an external ODBC database” on page 7-17).

5 Click the Language Selection tab and click Change tab to change the 
language if required.

6 Click OK.

Figure 9-15: Settings
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7 Select the Coder that will be used for printing. Click the Printer button. 
Under Select Printer option, select the required coder model. In this example, 
as we are using VJ1650, select Videojet > CLARiTY > VJ1650.

Figure 9-16: Select Printer
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8 Click on Communications tab.

9 If the coder is connected via serial port, enter the port number, baud rate and 
other details as required.

If the printer is connected using a TCP/IP network, enter the IP address of the 
printer that is being connected. Enter the port number (For further 
information, refer to your Coder Documentation).

10 To configure the method of job selection, click on the General tab and select 
the Job selection method as Database Record. Select the Job Selection 
Functionality as Download without selecting

Figure 9-17: Communications
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11 Select CIFFReference under Ciff Reference field to use or choose the 
database field name that contains the CIFF file name.

12 Click OK.

13 Click the Next Job button.The Select Job Code dialog box appears.

14 Following the database record for Job Code 1, double click on Mega Market.

15 From the Job Code 2 list, select Rice.

16 From the Job Code 3 list, select 500g.

Figure 9-18: Job Selection Method

Figure 9-19: Select Job Code 1
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17 From the UniqueJobCode list, select D002UK.

18 Click Finish. The Job Selection Confirmation dialog box appears. Verify that 
the preview is correct and click OK.

19 The job download starts. CLARiSOFT Print Manager displays the progress. 
Click Close when the download is complete.

Figure 9-20: Select Job Code 

Figure 9-21: Job Selection Confirmation

Figure 9-22: Progress
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20 At the coder’s user interface, touch the Job button. The transferred image 
appears in the job select list.

21 Select the job and touch OK.The selected job appears in the home page and is 
ready to be printed.

Figure 9-23: Job Select

Figure 9-24: Home Page
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CLARiSOFT Database Manager
CLARiSOFT Database Manager enables the user to create new and manage 
existing CLARiSOFT databases such as adding, deleting or modifying records.

CLARiSOFT Database Manager uses a specific database structure which must not 
be modified. It is possible to read and write to files created by CLARiSOFT 
Database Manager (it uses Microsoft Access .MDB format) however if the 
structure is not maintained, the database will no longer be compatible with 
CLARiSOFT Database Manager and will be rejected.

CLARiSOFT Database manager files may be read, and subsequently used by 
other programs, however CLARiSOFT Database Manager is unable to edit, or 
import, any type of existing database. If this is required, use ODBC to link 
CLARiSOFT to the database.

Opening the CLARiSOFT Database Manager
1 Open CLARiSOFT Database Manager.

2 You will be prompted to enter a Password. Enter the password.

Note: The default password is ‘admin’.

Figure 10-1: Enter Password
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3 The sample database is opened by default.

CLARiSOFT Database Manager Toolbar

Tool Description

New: Creates a new database using a wizard or an 
existing template.

Open: Opens an existing database

Login: Login to CLARiSOFT Database. The button is 
disabled when you are logged in.

Logout: Logout from CLARiSOFT. The button is 
disabled when you are logged out.

Add New Record: Add a new record (a record is the 
name of a row or job) to the opened database.

Table 10-1: CLARiSOFT Database Manager Tool Bar

Figure 10-2: Sample Database

Figure 10-3: Database Manager Toolbar
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Managing the Sample Database
CLARiSOFT is supplied with a sample database, that contains common data 
fields used in the product coding and marking industry. The sample database can 
be edited as required.

Edit Record: Edit the current record in the opened 
database.

Delete Records: Delete the current record from the 
database.

Copy Record: Copy the current record in the opened 
database.

Paste Record: Paste the copied record into the 
opened database. This button becomes enabled when 
you copy a record.

Print: Allows the user to print selected fields from the 
current database to a Windows printer.
Note: The printing options must be setup in 
File > Print before printing.

Set-up Database Properties: Configure the database 
structure (eg- field length, order etc).

About CLARiSOFT Database Manager: Displays the 
software version information.

Tool Description

Table 10-1: CLARiSOFT Database Manager Tool Bar (Continued)
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Adding a new job to the sample database
In this example, we will add a new job containing the data below to the sample 
database.

Note: We are using the templates in the default directory of CLARiSOFT Inner 
Primary Example1.ciff and Secondary Example1.ciff. Other templates may be 
created as .ciff files with the database entry linked with them.

1 Open the sample database from the default directory.

Note: To understand the structure of the CLARiSOFT Database, refer to 
“CLARiSOFT Database Structure” on page 7-2.

2 The sample database contains all the fields we need. Click Add New Record 
in the tool bar.

Unique Job Code D003UK

Job Code1 Super Market

Job Code2 Salmon Fillets

Job Code3 500g

Description UK 500g Salmon Fillets

SellByOffset 5 Days

UseByOffset 10 Days

CIFFReference Inner Primary Example1.ciff

Price £ 5.10 

AuxCiffReference Secondary Example1.ciff

Table 10-2: New Job Data
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3 The Add new record dialog box appears. Enter the UniqueJobCode for the 
new job (D003UK in this example) and click Create Job. The other data 
fields will become editable.

4 Enter the data as shown in Figure 10-4.

Note: If the AuxCIFF reference is not in use, use data from the earlier 
CIFFReference Field for the CIFF file in use.

Figure 10-4: Add New Record
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5 Click Save. The confirmation window appears (Figure 10-5).

6 Click Close to close the Add New Record dialog box.

7 The new record is added to the sample database.

Editing the Database
In this example, we will be making the following changes.

• Adding a new data field: ‘Packed In’

• Not using the data field ‘Description’.

• Adding the new data field ‘Packed in’ to the right of the column ‘Job Code 
3’.

1 Click on the row containing the job ‘D003UK’ we added in the previous 
example.

Figure 10-5: Confirmation

Figure 10-6: Updated Sample Database
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2 Click the Set-up Data Field Properties button in the toolbar. The Options 
dialog box appears.

3 Click the Add New Field button.

4 In the Add New Field dialog box, enter the Display Name as ‘Packed In’. 
Select the Data Type as Text and enter the Length as ‘20’.

Figure 10-7: Options

Figure 10-8: Add New Field
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5 Click Apply. The following confirmation window appears.

6 Click OK. The new data field appears in Table Configuration tab of the 
Options dialog box.

7 Select the field Description. Click on the check box Use this field to uncheck. 

8 Click Change Column Ordering button. Displays the Column Ordering 
Change Dialog Box.

Figure 10-9: Confirmation

Figure 10-10: Hide the field
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Note: Select Packed In and move up using the up arrow until it is placed 
below Job Code 3.

9 Click Apply.

10 Click Close to close the Options dialog box.

11 The Packed In data field is added next to the Job Code3 data field. The 
Description data field is hidden.

Note: To use the ‘Description’ data field again, click the ‘Set-up Database 
Properties’ button. Click on the ‘Description’ field and click on the check box 
‘Use this field’. A tick mark appears, indicating that this field is enabled.

Note: The data fields that we added during the worked example can be 
removed. ‘Unique Job Code’ and ‘CIFF Reference’ must always be enabled.

Figure 10-11: Column ordering

Figure 10-12: Sample Database showing modified data fields
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12 Click the job D003UK and click the Edit Record button. The Edit Current 
Record dialog box appears.

13 Enter the text ‘UK’ in the Packed In box under Your Items.

14 Click Save Changes. The following confirmation window appears.

15 Click Close to close the Edit Current Record dialog box. The new record is 
updated and displayed in the database.

Figure 10-13: Edit Current Record

Figure 10-14: Confirmation Window
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Creating a Database
The following four options can be used to create a database.

• CLARiSOFT Database Wizard: Guides the user through the steps required 
to build a new database.

• Primary Coding Template: A pre-defined database containing commonly 
used fields in primary product coding.

• Primary and Secondary Coding Template: A pre-defined database 
containing commonly used fields in primary and secondary product coding.

• Secondary Coding Template: A pre-defined database containing commonly 
used fields in secondary product coding.

CLARiSOFT Database Wizard
In this example, we will create a database, with four jobs, as shown below.

Product 1

Product 2

Product Description Spring Water

Internal Product Code 3WF

‘Use By’ Offset 365 Days

‘Sell By’ Offset 300 Days

UPC-A Data 0083046000135

UPC-E data None

Price $11.99

Table 10-3: Product 1

Product Description Cola

Internal Product Code RXD

‘Use By’ Offset 30 days

‘Sell By’ Offset 21 days

UPC-A Data None

UPC-E data 04904403

Price $12.99

Table 10-4: Product 2 
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Product 3
This product is shipped to two different customers: Customer A and Customer B.

1 Open and login to the CLARiSOFT Database Manager.

2 Click File > New to create a new database. The following dialog box appears.

3 Click Database Wizard and click OK. 

4 A prompt will be raised to select a name for the database. Enter the name 
‘New Database’ and click Save.

Product Description Energy Drink

Internal Product Code OGO (Customer A)

DWG (Customer B)

‘Use By’ Offset 45 days

‘Sell By’ Offset 35 days

UPC-A Data 0501234567890

UPC-E data 01213405

Price $8.99

Table 10-5: Product 3

Figure 10-15: New Database
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5 The Database Wizard launches. 

6 Click the Next button or the Start link in option 1.

7 Click on the check boxes for both Primary Packs and Secondary Packs under 
Use? as shown below.

8 Click Next. Commonly used fields will be presented in a table for review. 
Review Table 10-3 on page 10-11, Table 10-4 on page 10-11 and Table 10-5 
on page 10-12 to identify the data requirements for this example.

Figure 10-16: Database Wizard

Figure 10-17: Database Wizard
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Select the data requirements as shown in Figure 10-18. Note that the data 
field ‘Internal Product Code’ is not present in the commonly used fields.

9 Click Next. The wizard prompts if ‘Product Categories’ (i.e. ‘Product Tiers’) 
is to be used.

Product Tiers allow subcategories to be created which aids the selection of 
the correct record in the database for the job. For this example, we will create 
three tiers: PRODUCT, CUSTOMER, NONE. 

PRODUCT will allow the selection of any of the three products (Energy 
Drink, Cola or Spring Water).

CUSTOMER will allow the selection of either of the 2 customers for our 
'ENERGY DRINK' product. Therefore the selection of 'ENERGY DRINK'/
'OGO' will point to a distinct record in the database.

10 Click on the box Do you wish to use Product Categories?. 

Energy 
Drink

Customer A Unique Job Code 1 Ciff Reference 1 Auxiliary CIFF 
Reference 1

Customer B Unique Job Code 2 Ciff Reference 2 Auxiliary Ciff 
Reference 2

Table 10-6: Product tiers

Figure 10-18: Database Wizard
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11 Enter the required product categories into each level. First PRODUCT, next 
CUSTOMER.

12 Click Next.

Figure 10-19: Set Up Product Tier

Figure 10-20: Add / Edit Fields
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13 In this dialog box, existing field names selected above can be edited or new 
field names can be added. Click on Add New Item to enter the field ‘Internal 
Product Code’ as shown in Figure 10-21. Click OK.

Note: The following commonly used fields are not to be removed:

• UniqueJobCode

• CiffReferenceAux

• CIFFReference

Figure 10-21: Add New Item
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14 Click on the Item Name ‘Primary Pack Code’ and click Edit Item Name. 
Change the item name as ‘UPC-A data’. Click OK.

15 Click on the Item Name ‘Secondary Pack Code’ and click Edit Item Name. 
Change the item name as ‘UPC-E data’. Click OK.

16 Click Next. The Database is now ready to be created.

Figure 10-22: Edit Item Name

Figure 10-23: Data Entry Complete
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17 Click Create. The database is successfully created. Click Finish to exit the 
wizard.

18 The empty database will open and is now ready with the field names that 
were created. Click Add New Record to enter the details of the first record.

Figure 10-24: Finish Wizard

Figure 10-25: Empty Database
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19 Enter the ‘UniqueJobCode’ as 001 and click Create Job. Enter the other 
details as shown below.

20 Add records for ‘Product 2’ and ‘Product 3’. Note that ‘Product 3’ will have 
two unique job codes, one each for ‘Customer A’ and ‘Customer B’. The 
database will now have four records as shown below.

Refer to “Printing a Job Linked to a Database” on page 9-11 for more 
information on printing.

Figure 10-26: Add Record

Figure 10-27: New Database
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